WordPress.org

Ready to get started?Download WordPress

Forums

Transposh WordPress Translation
[resolved] [Plugin: Transposh - translation filter for wordpress] [plugin: Transposh] Numerical values & pu (10 posts)

  1. smartyd
    Member
    Posted 2 years ago #

    Transposh is one of the best things that have happened to me in my website experience. I love the interface & the fact that it creates semi-translated pages (it's easier to fix a bad translation than to do one from scratch), etc. However, when it comes to numerical values and punctuation, nothing I do [that's been suggested] allows me to edit them. I've changed the TRUE to FALSE in the parser.php as per:

    * Date: Tue, 02 Aug 2011 03:11:42 +0300
    */

    require_once("shd/simple_html_dom.php");
    require_once("constants.php");

    require_once("utils.php");

    define('PUNCT_BREAKS', TRUE); // Will punctiations such as , . ( and such will break a phrase
    define('NUM_BREAKS', TRUE); // Will a number break a phrase
    define('ENT_BREAKS', TRUE); // Will an HTML entity break a phrase

    /**

    But still no luck getting those values to become editable.
    Anyone else succeed in fixing this?
    Thanks

    http://wordpress.org/extend/plugins/transposh-translation-filter-for-wordpress/

  2. smartyd
    Member
    Posted 2 years ago #

  3. Ofer Wald
    Member
    Plugin Author

    Posted 2 years ago #

    The change should work, might be you have some sort of cache interrupting?

  4. Andrew
    Member
    Posted 1 year ago #

    I also have the same issue. Changing number breaks and punctuation breaks to FALSE does still not allow those entities to be translated.

    Hmm..

    Ofer the site url is http://yogamalafoundation.org/dev

  5. Andrew
    Member
    Posted 1 year ago #

    user: twoguys
    pw: [ Moderated - Assuming that's a real password, yeah, don't do that. ]

  6. Andrew
    Member
    Posted 1 year ago #

    Thanks for any help you can provide. I know you give your time freely as you are able.

  7. Ofer Wald
    Member
    Plugin Author

    Posted 1 year ago #

    Andrew, please change pass ASAP, this is a public forum

  8. Andrew
    Member
    Posted 1 year ago #

    Hey Ofer, It's not WP credentials, but just the login required to view the development site (protected directory). I think they worst that can happen is that I get a few more user registrations in my buddypress site. :-)

  9. Andrew
    Member
    Posted 1 year ago #

    Hmm, Well I've tested the plugin on my local server on another install of WordPress and changing these values

    define('PUNCT_BREAKS', TRUE); // Will punctiations such as , . ( and such will break a phrase
    define('NUM_BREAKS', TRUE); // Will a number break a phrase

    to FALSE, does indeed take care of the problem and I'm able to edit the numerical values and punctuation. So I went back to investigate the issue with my dev site and.. it was working properly...... ????

    My only conclusion is that because I had activated the WP-Super Cache plugin before making changes to the parser.php file, that even afterwards I was getting served the old cached files.. So in that case I was still seeing the problem. Does that sound like a reasonable explanation?

    As a WordPress professional I have a hard time with not knowing what the problem is even when the problem disappears. Any thoughts or guidance would be great. If people are in agreement with my hypothesis I'd be tempted to mark this one resolved..

  10. Ofer Wald
    Member
    Plugin Author

    Posted 1 year ago #

    Yes, caching does seem like a very reasonable answer.

    We actually support wp-super-cache, but not for those types of changes...

    Maybe its time we'll finish the feature that will make those options redundant...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic