WordPress.org

Ready to get started?Download WordPress

Forums

Transposh WordPress Translation
[resolved] [Plugin: Transposh - translation filter for wordpress] invalid xhtml after translation is breaking t (5 posts)

  1. wp.Man
    Member
    Posted 2 years ago #

    about half of the languages i have activated have these errors when validating xhtml trans 1.0

    these errors seem minor to me, but apparently they are enough to cause the pages to not translate fully

    there is no attribute "data-token"
    there is no attribute "data-source"
    there is no attribute "data-orig"
    there is no attribute "data-hidden"

    Bengali (BN)
    http://12bytes.org/?lang=bn

    Norwegian (NO)
    http://12bytes.org/?lang=no

    Romanian (RO)
    http://12bytes.org/?lang=ro

    Russian (RU)
    http://12bytes.org/?lang=ru

    Swedish (SV)
    http://12bytes.org/?lang=sv

    http://wordpress.org/extend/plugins/transposh-translation-filter-for-wordpress/

  2. wp.Man
    Member
    Posted 2 years ago #

    note that some of the above are now valid, but not all. and i haven't changed anything

    i also notice that one page will be valid both before and after translation, while another will not...

    valid before:
    http://12bytes.org
    valid after:
    http://12bytes.org/?lang=sv

    valid before:
    http://12bytes.org/contact/support-request
    invalid after:
    http://12bytes.org/contact/support-request/?lang=sv

  3. wp.Man
    Member
    Posted 2 years ago #

    again this has changed without any changes on my part

    now these 2 are valid before translation, but not after...

    http://12bytes.org/?lang=bn
    http://12bytes.org/?lang=ru

  4. Ofer Wald
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    Those attributes are used in the translation process, and they are valid html5 attributes with no influence (that I have seen) on other doc types.

    when the page is fully translated, they will go away, the quota issues of google/msn are making this take more time now

    Good luck

  5. wp.Man
    Member
    Posted 2 years ago #

    well i set bing as preferred and am using my own API key - we'll see what happens

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic