WordPress.org

Ready to get started?Download WordPress

Forums

TPG Get Posts
[resolved] "Read More" link not working correctly (5 posts)

  1. rachelsstorm
    Member
    Posted 2 years ago #

    I'm using the TPG Get Posts plugin to display a couple of news items on our website's front page. Trouble is, when there are links in the posts, it's changing the "Read More" link. If you go to the website at http://www.fordlibrary.org you can see what I mean. There are currently two posts under "Library News".

    Is there a way to fix this? Aside from just not using links, of course...

    http://wordpress.org/extend/plugins/tpg-get-posts/

  2. cswaim
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Rachel:

    I am not clear on the problem.

    Would you post the shortcode you are using to pull the posts and explain what you would like the output on the read more to be? If you could include a snippet of the post with the link, that would be helpful.

    Also, make sure you are on the most recent version of the plugin. There was an issue with read more showing on every post in an earlier release.

  3. rachelsstorm
    Member
    Posted 2 years ago #

    The code to pull the posts is as follows:

    [tpg_get_posts numberposts=2 category=17 show_meta="false" show_byline="false" title_tag="h3" show_entire="false" shorten_content="c125" ]

    The "read more" should really link to the full post, so in the case of the first item that's there-- right now, it has a broken link of:
    http://www.p4aantiquesrefe%20...%20%3Ca%20href%3D/

    I recognize some of that as being from the first link in that post. The first couple sentences of the post are:

    "The library has a new resource to help you research antiques, collectibles and fine art!
    Antiques Reference updates daily to provide detailed information about pieces that have sold at over 140 U.S. auction houses."

    Where "Antiques Reference" links to:
    http://www.p4aantiquesreference.com/library/westernsprings.asp

    It should link to the same page that the title of the post (Antiques Research) is linked to (http://fordlibrary.org/antiques-research).

    I am definitely 100% updated, so I'm on the latest release of this plugin.

    It occurs to me now that it could be due to the links ending up being part of the character limit, I could play with the text or limit for a quick fix on my end I suppose.

  4. cswaim
    Member
    Plugin Author

    Posted 2 years ago #

    Are you familiar with the more tag when editing post?

    in the post editor on the top row of icons, there is one which inserts a more tag. This tag breaks the post at the spot and a (read more...) link is inserted in the post when displayed.

    the tag is <!--more-->.

    the shorten_content just counts the number of characters and truncates the post. I can be in the middle of anything. It's use was to create a list at a specific length for creating menus, but it requires some discipline on post entries.

    You can modify the wording on the more tag at either the insertion of the tag or with an option on the plugin.

    see if you can use the more tag without any formatting and then add the formatting.

    Please post your results.

  5. rachelsstorm
    Member
    Posted 2 years ago #

    Yes that worked perfectly! I went into each post and added the "more" tag where I wanted it and now the "read more" links on our main page are working correctly! Thanks! :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.