WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Top Commentators Widget] WordPress 2.5 Error (10 posts)

  1. plutopsyche
    Member
    Posted 6 years ago #

    I'm getting the following error in the Widgets screen in WordPress 2.5.0 (it worked great up to 2.3.2).

    Fatal error: Cannot redeclare ns_substr_ellipse() (previously declared in /home/plutonic/public_html/blog/wp-content/plugins/topcommentators_widget.php:26) in /home/plutonic/public_html/blog/wp-content/plugins/topcommentators_widget.php on line 26

    Any ideas?

    Thanks!

    http://wordpress.org/extend/plugins/top-commentators-widget/

  2. majormike01
    Member
    Posted 6 years ago #

    When I activate Top Commentators Widget (ver .999) in WorPress 2.5.0 all the succeeding widgets don't appear in the widget list and the save changes button disappears.

  3. Tari
    Member
    Posted 6 years ago #

    I confirmed the first Post, I got the same Error... any suggestions to solve this ?

  4. Tari
    Member
    Posted 6 years ago #

    *bump* nobody? :(

  5. FreeKill
    Member
    Posted 6 years ago #

    This is easy to fix, it's just an issue with the way that the original plugin is written and to how things get called in 2.5.

    just open up the plugin in a text editor and move the following 3 functions outside the scope of the functions they are in:

    ns_substr_ellipse
    ns_get_user_url
    ns_show_top_commentators

    Anyway, if you want the changes, I put my modified file back into the top commentators zip file. You can grab it if you want, but use at your own risk :) The changes I made are working fine over at my blog:
    Groovy Grooves

    Top Commentators Hacked Changes

  6. ails
    Member
    Posted 6 years ago #

    Cheers for that, it works a treat.

  7. Tari
    Member
    Posted 6 years ago #

    woohoo, works great, thank you FreeKill!!

  8. ronchicago
    Member
    Posted 5 years ago #

    i have installed the hacked version ( thank you! ) of this plugin and have two questions...

    1) it does not show my top/any commentors prior to the install, just the ones after the install.

    2) also, the title does not appear

  9. ronchicago
    Member
    Posted 5 years ago #

    well, i went back into the options menu and it was back to default mode so i again typed in the title = title appeared.

    then i added 10 commentators - the field was blank - and now the commentators i did have after the install now displays = no commentators

    i also changed the default one month recycle to one hour and maybe commentors will appear in an hour?

  10. webgrrrl
    Member
    Posted 5 years ago #

    Thanks for the bug report and sorry for the long delay. Hopefully the latest release fixes the errors everyone has mentioned above.

Topic Closed

This topic has been closed to new replies.

About this Topic