WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: TinyMCEComments] Blockquote not working (13 posts)

  1. TomGCCC
    Member
    Posted 5 years ago #

    Blockquote is not working for me. Is there a way to downgrade to a prior version?

  2. mk_is_here
    Member
    Posted 5 years ago #

    Older versions are here. I've just tagged the 0.4.3-2 version, please wait for a while until it appeared in the page.

    You could then download and replace the existing plugin files.

  3. bile
    Member
    Posted 5 years ago #

    I've updated to 4.5 and this issue still exists.

  4. mk_is_here
    Member
    Posted 5 years ago #

    I've updated to 4.5 and this issue still exists.

    Does the blockquote tag exists when you view in the admin interface?

  5. ndna
    Member
    Posted 5 years ago #

    My blockquote tag doesn't work, too
    Version: 0.4.5
    WordPress 2.6

  6. Anonymous
    Unregistered
    Posted 5 years ago #

    thanks & regard

    You could then download and replace the existing plugin

  7. I'm also have the same issue with 4.5, it took awhile just to add the block quote image into the editor but the button does not work. I can't quote anything.

  8. highlite15
    Member
    Posted 5 years ago #

    The blockquote is also not working for me as well on Version: 0.4.5. The blockquote tag does exist in both the admin interface and on my comment form. But when I push the tag I get no action.

  9. mk_is_here
    Member
    Posted 5 years ago #

    If the blockquote tags does exists in the admin interface comments section, that means your theme does not handle well on that.

  10. cafecroissant
    Member
    Posted 5 years ago #

    Same issue with the blockquote and WP 2.6, but I tried it on several theme ( over 10 , including the default wp one)
    Any one have the blockquote working with WP 2.6 ?

    Thanks

  11. elminster
    Member
    Posted 5 years ago #

    I'm not sure if your problem is with all browsers or just with Firefox. If so, just try if it works by changing the following line in the plugin script from

    $res .= 'forced_root_block : "",'.$le;

    to

    $res .= 'forced_root_block : "p",'.$le;

    For me that did the trick (even since TinyMCE says that this is set to p by default if left empty).

    I did some additional changes but they should have no influence on this problem (I wanted new paragraphs on enter and had problems with the right language setting). Just in case... All my changes:

    $res .= 'force_p_newlines : false,'.$le; TO $res .= 'force_p_newlines : true,'.$le;
    $res .= 'force_br_newlines : true,'.$le; TO $res .= 'force_br_newlines : false,'.$le;
    $res .= 'forced_root_block : "",'.$le; TO $res .= 'forced_root_block : "p",'.$le;
    $res .= 'save_callback : "brstonewline",'.$le; TO //$res .= 'save_callback : "brstonewline",'.$le;
    $res .= 'language : ""'.$le; TO $res .= 'language : "'.$mcecomment_options['language'].'"'.$le;

    echo '<script type="text/javascript" src="'.get_option('siteurl').'/wp-includes/js/tinymce/langs/wp-langs-' . $mcecomment_options['language'] . '.js"></script>'."\n";
    TO
    echo '<script type="text/javascript" src="'.get_option('siteurl').'/wp-includes/js/tinymce/langs/' . $mcecomment_options['language'] . '.js"></script>'."\n";

  12. kuma32478
    Member
    Posted 4 years ago #

    When I try to use the blockquote icon on my site, I click and click and nothing happens to the text.

    http://www.viewfromthebleachers.com is the site and my contact e-mail is joe@viewfromthebleachers.com

    Anyone able to lend a hand?

  13. Daemony
    Member
    Posted 4 years ago #

    I'm not sure if your problem is with all browsers or just with Firefox. If so, just try if it works by changing the following line in the plugin script from

    $res .= 'forced_root_block : "",'.$le;

    to

    $res .= 'forced_root_block : "p",'.$le;

    elminster, THANK YOU!

    It's real solution to the problem - the 'p' tag.

    I had same problem with blockquote button in MCEComments. There is was no effect by click on button, when comment text has no any formating. But if add < div > or < p > tag it's become all right.

    Thanks for your code changes, it's made default < p > in < blockquote > tag.

Topic Closed

This topic has been closed to new replies.

About this Topic