WordPress.org

Ready to get started?Download WordPress

Forums

TinyMCE Advanced
Slowly losing my mind - table cells issue (17 posts)

  1. Tony
    Member
    Posted 3 years ago #

    I've tried so many ways but can't seem to figure it out...

    When I make a table with TinyMCE advanced plugin, the text inside every cell is too close to the top of the cell... it's actually touching the top of the cell...

    Can someone please tell me what's wrong? Could it have anything to do with CSS? How do I fix this?

    Help will be greatly appreciated.

    -Tony

  2. You can add table cell padding in your CSS. If you need further help, please post a link to a page or post with a table where the spacing isn't how you want it.

  3. Tony
    Member
    Posted 3 years ago #

    [URL removed by request of user].
    I'm a wordpress rookie so as much detailed help as possible would be great.

    Thanks for responding.

    -Tony

  4. Each of your table cells has a bit of HTML in it that should be removed:

    valign="top"

    Is there a way to remove that top vertical alignment within the TinyMCE Advanced editor? That should get your text back in the middle of each cell again.

  5. Tony
    Member
    Posted 3 years ago #

    I don't see that code in the TinyMCE editor... what would you suggest? I see an 'Editt CSS Style' button in the editor but I don't know if that's TinyMCE?

  6. Do you see anything in the TinyMCE Advanced interface for cell alignment? You can switch to HTML view to remove the code I pointed out above, but it's in every single cell and it would probably be easier to do with the WYSIWYG editor. (p.s. this is not CSS - it's the HTML code itself)

  7. Tony
    Member
    Posted 3 years ago #

    TinyMCE editor gives me three options for tables... I can edit the table, I can edit the row, I can edit cells... I would think either table or cells would make sense...

    When I click on the Edit Table button, there's a dropdown for Alignment and I can choose - not set, center, left, or right... it's currently "Not Set"

    When I click on the Edit Cells button, there's a dropdown for Alignment and Vertical Alignment... For Alignment I can choose - not set, left, right or center, and for vertical alignment I can choose - not set, top, center or bottom... Alignment is currently "Not Set" and vertical is "Center".

  8. Tony
    Member
    Posted 3 years ago #

    Edit cells also gives me the option to apply the changes to "All Cells"

  9. Hmm, interesting that vertical alignment is set to "center" as it reads "top" in the code.

    Can we do a test on part of the table, switching to HTML view? Do you see valign="top" in the code? If yes, can you remove a bunch of them (careful to keep the rest of the code intact) and save the post. Let me know.

  10. Edit cells also gives me the option to apply the changes to "All Cells"

    You could also try a test, using this option, and setting vertical alignment to "Not Set" since that defaults to the middle.

  11. Tony
    Member
    Posted 3 years ago #

    I removed a bunch of valign=top codes and previewed the post (didn't want to save) and still didn't see a difference.

  12. Tony
    Member
    Posted 3 years ago #

    Could you suggest a different plugin for tables?

    Another issue I have with this table is that the backround of every other row on the table is shaded grey on some web browsers... but on other web browsers the backround of all the rows are white? I want the backround color of every other row to be grey all the time on all web browsers not just some...

    Any advice? Alternative plugins? Thanks for trying.

  13. Andrew Ozz
    WordPress Dev
    Plugin Author

    Posted 3 years ago #

    @acfurino where did you copy these tables from? Word? Dreamweaver? They contain some "prehistoric" attribs like width, height, valign, etc. mixed with some very basic inline css.

    If you really want to fix them you will need to delete all formatting attributes and all inline css, then add couple of table styles to your theme. You can copy the table styles from another theme or write them yourself (not that hard if you use Firefox + Firebug to test your changs). So the HTML for your tables should look like this:

    <table>
    <tr>
    <td>something here</td>
    <td>some more here</td>
    </tr>
    </table>

    i.e. there shouldn't be any v-align, css, width, height, etc. in there (that is controlled by the theme's css).

  14. Tony
    Member
    Posted 3 years ago #

    I don't know I guess it's the TinyMCE plugin... Could you please suggest a different plugin for tables? I'm a wordpress rookie so I'm not good with codes.

    Any help will be appreciated...

  15. Tony
    Member
    Posted 3 years ago #

    Can ANYONE suggest a plugin for a table?

  16. Andrew Ozz
    WordPress Dev
    Plugin Author

    Posted 2 years ago #

    That has nothing to do with TinyMCE or the plugin. Seems you copied and pasted the tables that were created with bad HTML in the first place.

  17. rehtaeh
    Member
    Posted 2 years ago #

    Hey everyone, I'm having the same issue with the table cell padding and spacing using tinymce advanced. I'm using Headway themes as well but the headway forums have suggested it's not a headway issue.

    the url is http://www.consciousmusicmovement.com and the page i'm having trouble with in regards to the table cell padding/spacing is http://www.consciousmusicmovement.com/festival-2012/cm-fest-sponsors

    can anyone please help me with this - I've been looking all over the place in forums for an answer but nothing has really helped - it's slowly driving me crazy!

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic