WordPress.org

Ready to get started?Download WordPress

Forums

TinyMCE Advanced
editor-style.css not working (15 posts)

  1. yamrd200
    Member
    Posted 2 years ago #

    Custom styles are not appearing the 'Style' dropdown list, works find in previous WordPress platform 3.2. Will there be a fix soon?

    http://wordpress.org/extend/plugins/tinymce-advanced/

  2. Cssmeasap
    Member
    Posted 2 years ago #

    I'm also having trouble with the drop-down styles.
    Changes I make to editor-style.css in the parent theme (2011) seem to make no difference to the styles drop-down in TinyMCE Advanced.
    Is there a different method for a child theme?
    Or am I placing the file in the wrong location?

    Thanks for the help!!!

  3. Andrew Ozz
    WordPress Dev
    Plugin Author

    Posted 2 years ago #

    Best way to control what is in the Styles drop-down is to set the option in TinyMCE. To do that you can use http://wordpress.org/extend/plugins/advanced-tinymce-configuration/ (only be careful and read all relevant help as that plugin gives access to the low-level editor settings).

    All browsers don't refresh the css for the editor iframe, even when force-refreshing the page. After editing editor-style.css you need to empty the browser cache and then restart it, sometimes repeating this 2-3 times before the new css loads.

  4. trinzia
    Member
    Posted 2 years ago #

    About caching, it helps also to hold Shift while reloading in Firefox. To see my styles, I had the best luck when doing that shift-reload once on Dashboard, and sometimes again in page. And using Firebug to see if the styles were there or not, because sometimes it is my CSS targets that are wrong.

    You could also try going to your Adv MCE settings page in Admin, and redrag the selectbox onto the bar, because it worked fine for me yesterday when I installed, once I figured out to go to that Settings page. :)

  5. camu
    Member
    Posted 2 years ago #

    Hi all,

    I have the same problem here. I'm using WordPress 3.4 and the latest version of Andrew's plugin. According to Firefox, there's something wrong in the javascript:

    Uncaught TypeError: Object [object Object] has no method '_add' /wp-content/plugins/tinymce-advanced/tiny_mce_popup.js?ver=349:5

    Any idea of what this means?

    Camu

  6. chiefTomato
    Member
    Posted 1 year ago #

    I've been messing around with this forever and trying all the post suggestions also. I don't see any reference that the styles dropdown looks at the editor-style.css. Didn't there use to be a checkbox under "Advanced" to "import editor-style.css"?

    Through testing the various stylesheets, what I've found is it loads class styles that are included in the "content.css" file located here:
    /wp-includes/js/tinymce/themes/advanced/skins/wp_theme/content.css, which is where I also commented out the default ones: aligncenter, alignleft, alignright, wp-caption, wp-cation-dd, wp-gallery and wp-oembed.

    Anyone else try this?

  7. hydrurga
    Member
    Posted 1 year ago #

    I had the same problem. I noticed from WordPress's support tracking that the author of this plugin noticed a bug with WordPress 3.4 which caused the problem mentioned above and raised a ticket with them (thanks for that). The problem mentioned above was resolved in the 3.4.1 release and upgrading to that version solved my problem.

  8. insurgenesis
    Member
    Posted 1 year ago #

    @hydrurga so you're saying that custom styles will reflect in the drop-down when one upgrades from 3.4 to 3.4.1?
    Do you maybe have a link reference for support tracking?
    Thanks

  9. hydrurga
    Member
    Posted 1 year ago #

    @insurgenesis, if everything else is set up right then it should do - it worked for me pre-3.4, didn't work for me 3.4, worked for me 3.4.1, with no other changes than updating the WordPress version. Regards the tracking, I had it wrong, the owner of the bug was the plugin author but the ticket was raised by another user: http://core.trac.wordpress.org/ticket/21026

  10. insurgenesis
    Member
    Posted 1 year ago #

    @hydrurga, do you to use Advanced TinyMCE Configuration plugin in conjunction with TinyMCE Advanced to get the styles to show,
    or was it the upgrade that ensured it?

  11. hydrurga
    Member
    Posted 1 year ago #

    @insurgenesis: just the WP upgrade. I don't use the Advanced TinyMCE Configuration plugin.

  12. insurgenesis
    Member
    Posted 1 year ago #

    @hydrurga, that clears things up but I've not had any success doing that. May I ask you to outline the process you followed? Maybe I'm missing something. Thanks.

  13. insurgenesis
    Member
    Posted 1 year ago #

    @hydrurga: which version of the plugin are you on? - because I don't see "import editor-style.css"...

  14. insurgenesis
    Member
    Posted 1 year ago #

    @Andrew Ozz,
    I've tried your suggestion. BTW this: http://wordpress.org/extend/plugins/advanced-tinymce-configuration/
    is not a usable solution for general users. The mere fact that this thread accumulates this many responses should tell you that many general users rely on this plugin's ability to to import custom styles.

    Anyway, it shouldn't be necessary to fiddle with Advanced-tinymce-configuration when TinyMCE Advanced claims it can do so. I'd be damned if it can't.

    There used to be an option for including/importing custom styles in settings but that's no longer the case, and I certainly don't see it in mine. What are the check I can do to resolve this?
    Thanks

  15. hydrurga
    Member
    Posted 1 year ago #

    @insurgensis: I'm running WP 3.4.1 and TinyMCE Advanced 3.4.9. The only setting I have checked for TinyMCE Advanced is Advanced Image. I have the file editor-style.css in my child theme which contains the line:

    @charset "UTF-8";

    followed after a blank line by several style declarations e.g.

    .brown-normal { font-size: 16px; color: #502800; font-weight: bold }

    These identical style declarations are also included in the file style.css in the child theme.

    When I click on the Styles drop-down box in the TinyMCE Advanced editor, these styles are automatically available to me.

    It was a while ago that I set this up so I hope that I haven't omitted any details. I don't, as far as I can see, use any sort of import editor-style.css command.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic