WordPress.org

Ready to get started?Download WordPress

Forums

TinyMCE Advanced
editor-style.css not being accessed (33 posts)

  1. Ray Gulick
    Member
    Posted 2 years ago #

    With latest version of TinyMCE Advanced (3.4.5), the styles in editor-style.css are no longer being rendered in the editor.

    http://wordpress.org/extend/plugins/tinymce-advanced/

  2. bottleneck
    Member
    Posted 2 years ago #

    I got the same problem. The editor-style.css file won't be rendering in both TinyMCE Advanced plugins version 3.3.9.2 and 3.4.5 after upgrading to WP 3.3

  3. Andrew Ozz
    WordPress Dev
    Plugin Author

    Posted 2 years ago #

    Can you look in the HTML source and search for something like: content_css:"http://[your site]/themes/twentyeleven/editor-style.css". If this exists, the problem is the browser cache. If not, could you provide your theme's names and whether you're using this plugin to add support for "editor-style.css".

  4. bottleneck
    Member
    Posted 2 years ago #

    Hi, Andrew.

    Thanks for looking into this matter.

    Sure enough, I deleted both Twenty Eleven 1.3 and Twenty Ten 1.2, it didn't help.

    We use Fastway 2.0. but right now that page doesn't show themes, probably the author redesigned his site.

    To make this story shorter, we have customized css file to insert tiny userpic/icons from pull-down menu while working on posts. It was fine until version 3.3.9.2, then we put a separate editor-style.css:

    img.userpic{
    	float:left;
    	padding:0 5px 5px 0;
    	border: 0 none;
    }
    
    .wmv-link,
    .mp3-link,
    .word-link,
    .pdf-link,
    .html-link,
    .a-link {
    	padding: 0 0 4px 20px;
    	margin:5px 5px 0 0;
    	line-height:20px;
    	font-size:80%;
    }
    .a-link {
    	padding: 0 0 4px 4px;
    }
    .word-link {
    	background: #FFF url(images/word-icon.gif) no-repeat 0 0;
    }
    .pdf-link {
    	background: #FFF url(images/pdf-icon.gif) no-repeat 0 0;
    }
    .html-link {
    	background: #FFF url(images/txt-icon.gif) no-repeat 0 0;
    }
    .mp3-link {
    	background: #FFF url(images/mp3-icon.gif) no-repeat 0 0;
    }
    .wmv-link {
    	background: #FFF url(images/wmv-icon.gif) no-repeat 0 0;
    }

    and everything started working fine again.

    After upgrading to WP 3.3, we're unable to bring it back.

    Thanks again for your support.

    Meantime I found version 3.2.7 and it works with WP 3.3, meaning we are able to pull our icons.

    M.

  5. JunoMagic
    Member
    Posted 2 years ago #

    I have the same problem. Is there a solution yet?

  6. bottleneck
    Member
    Posted 2 years ago #

    Is there a solution yet?

    My own workaround is using version 3.2.7

  7. Hans Magnus Mikalsen Nedreberg
    Member
    Posted 2 years ago #

    @bottleneck:
    You actually rolled back all the way to 3.2.7?
    I downgraded to version 3.4.2.1 but it didn't help. It doesn't import editor-style.css

    No news yet?

    - HM

  8. bottleneck
    Member
    Posted 2 years ago #

    @bottleneck:
    You actually rolled back all the way to 3.2.7?

    Sure, I did.
    Keep in mind, I need only user pics for my editors being available. It works with 3.2.7
    Other 3.2.7 features could not be working with WP 3.3, I didn't check.

  9. mozakdesign
    Member
    Posted 2 years ago #

    Same issue here

  10. Hans Magnus Mikalsen Nedreberg
    Member
    Posted 2 years ago #

    I'm actually starting to think that it is my own setup that breaks it. I've now installed TinyMCE Advanced on two of my WP installations (both WP 3.3.1), and editor-style.css works fine on one of them. The working installation is only running 8 plugins, but the broken install runs 27. So I guess I'll have to go through them one by one to see if any of them interferes.

  11. johnflufin
    Member
    Posted 2 years ago #

    Same problem here using TMCE Adv 3.4.5 and WP 3.3.X. editor-style.css is not being loaded as evident in the edit page source. After some investigating this could be related to the latest WP 3.3.x upgrades...

    • Disabling TinyMCE Adv plugin does not fix
    • Another site running WP 3.2.1 loads editor-style.css just fine. This site also uses the same plugins although some have not been updated recently so there could be a conflict with a plugin update.

    I can't be sure but I'm guessing this problem is related to WP 3.3.X upgrades or a plugin conflict.

  12. JunoMagic
    Member
    Posted 2 years ago #

    I think it must be the WP upgrade that killed this feature because I don't use any plugins that could possibly interfere with this tool.

    I'll try going back to the older version of that plugin now, too.

    Really hope this gets fixed sometime!!!

  13. johnflufin
    Member
    Posted 2 years ago #

    Upon further testing, I discovered that the latest version of the White Label CMS plugin is preventing the editor-style.css file from loading. Disabling WLCMS allows editor-style.css to load. I have posted this issue in the WLCMS forum.

    Whether this is related to the latest WP upgrade I can't say but since I'm also having other issues with the latest WLCMS, I'd have to say that it's the culprit. However I'm sure it's possible other plugins could cause the same issue.

  14. Hans Magnus Mikalsen Nedreberg
    Member
    Posted 2 years ago #

    @johnflufin
    You're right regarding the WLCMS, deactivating it brings back the editor-style.

    However, I've also encountered other irregularities with TinyMCE Advanced recently. Amongst others, the "Insert / edit link" functionality sometimes is broker (lists no internal pages, Add Link brings you out of edit page).

    So I'm not sure if it really is WLCMS, or if TMCE is reacting badly to other plugins as well.

  15. Video User Manuals
    Member
    Posted 2 years ago #

    Hi - we have just discovered that WLCMS may be overriding the custom edit style sheet, even if one isn't set.

    We have fixed this and will be releasing as part of 1.4.3 - which should not be far away.

  16. mozakdesign
    Member
    Posted 2 years ago #

    I have tried disabling all plugins except for TinyMCE Advanced and still see the issue

  17. johnflufin
    Member
    Posted 2 years ago #

    @mozakdesign

    Try clearing your browser cache and making sure TMCE Adv and WP are up to date. Otherwise I'm sure there's more than one way for this problem to occur (not WLCMS).

  18. jho1086
    Member
    Posted 2 years ago #

    I have same problem, the editor works fine before, I did not add plugin but I upgrade the site in wp 3.3.1 and the tiny MCE to v(3.4.5). I done all the suggestion above except downgrading, but still not work.

  19. grahamjones
    Member
    Posted 2 years ago #

    Same problem with my sites - no access to styles having cleared browser cache and disabled other plugins. Happened after upgrade to WP 3.3.1

  20. ecila
    Member
    Posted 2 years ago #

    I have the same issue and a rather upset website user ... any solutions welcomed ...

  21. steveb123
    Member
    Posted 2 years ago #

    I deleted the latest upgrade and reinstalled 3.2.7. It works perfectly with WP 3.31

  22. relish1227
    Member
    Posted 2 years ago #

    I also am having this issue... would be great if the latest TinyMCE Advanced plugin worked with the latest WP. I set up custom styles for most of my clients, so this is a problem.

  23. KennyLL
    Member
    Posted 2 years ago #

    We're testing upgrading our sites to WP 3.3.1 and just happened to notice this little bug. We don't use styles for much, but there are a couple that are necessary.

    We thought about going back to 3.2.7, but I think there were other features and bug-fixes added after that version that we would like to keep.

    So we ended up trying a hack that someone mentioned in the Feb. 2 comment on the TinyMCE Advanced plugin homepage.

    Basically, it looks like just using a bit of the old code from 3.2.7 to force the tadv-mce.css file to be loaded. Since I don't believe that file is included in 3.4.5, we added it with just an '@import' to point to our editor-style.css file in our Theme. If I knew PHP I would probably have been able to have the code point directly to the editor-style.css file and bypass the 'tadv-mce.css' file altogether, as I don't think that's been used for a few versions (correct?!?).

    Hopefully this will suffice until a proper fix can be published. I'm pretty sure we don't lose any of the features from 3.4.5, just get the style sheet loading again. I'm sure someone who knows PHP well could figure out a better and more permanent solution much quicker. I'd love to hear about it!

  24. KennyLL
    Member
    Posted 2 years ago #

    Just a bit more after some testing.

    It appears that we started getting the issue of styles working until we updated the page/post, then they disappeared (even after our hack mentioned above) when in Safari (FF fine). So it looks like we got the bug described here.

    Just not sure if we got this bug after doing our 'hack' fix, after updating WP to 3.3.1, after updating TinyMCE Advanced to 3.4.5, or if we just had never noticed it before.

    At any rate, we installed the TinyMCE Advanced Configuration plugin mentioned in the other thread (not happy about yet another plugin), and it did actually work - styles no longer disappear in Safari. So we now get a drop-down list of JUST the styles we want our client to see (none of the default WP ones). And we even make an entry to limit the formatting choices to only those we use as well. So this is actually better than it was before.

    Just hoping the TinyMCE Advanced Configuration plugin doesn't cause other issues, and that when this whole things gets completely fixed properly, we don't have issues when updating now.

  25. relish1227
    Member
    Posted 2 years ago #

    Just noticed this again in another fresh install. I feel like it has worked in previous versions that were upgraded to the latest and greatest. Is there any update on this?

  26. steveb123
    Member
    Posted 2 years ago #

    I just carried on using Tiny 3.2.7. It works perfectly with latest wordpress.

  27. smitty01140
    Member
    Posted 2 years ago #

    I am having the same issue. Running WordPress 3.3.2, TinyMCE Advanced 3.4.5.1 and using the BlankSlate theme.

    Any solutions on fixing this?

  28. steveb123
    Member
    Posted 2 years ago #

    Hi Smitty,
    Go to the plug in web site and download 3.2.7 it works and it's simple to achieve the desired result

  29. smitty01140
    Member
    Posted 2 years ago #

    I downgraded it shows up in the dropdown, but if I go to a different page it disappears.

  30. steveb123
    Member
    Posted 2 years ago #

    I just checked a lot of my pages and it shows up in all the ones I looked at.This may be of no use whatsoever, but it may be worth a try (??) Empty your cache and loo at the pages again. Other than that I don't kno what to suggest. Once I found the latest Tiny MCE was not working I downloaded the older version and used that. In tiny settings, I have both boxes ticked in settings (Tiny MCE) and I also ignored the instructions for Tiny MCE and copied and pasted the full style description rather than just the name of the style into the theme style sheet e.g
    }
    .songtitle {
    color: #e7dd9c;
    font-weight: bold;
    }

    rather than just
    .songtitle

    Hope this helps

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic