WordPress.org

Ready to get started?Download WordPress

Forums

Timthumb Vulnerability Scanner
311 characters of unexpected output upon activation (4 posts)

  1. spherical
    Member
    Posted 2 years ago #

    Getting this with 1.4.3. Looked at the code and checked for whitespace and nesting but that's evidently not it. Plugin seems to work OK.

    http://wordpress.org/extend/plugins/timthumb-vulnerability-scanner/

  2. jayPEG
    Member
    Posted 2 years ago #

    I received the same thing with the exception of 353 characters.

  3. Peter Butler
    Member
    Plugin Author

    Posted 2 years ago #

    Hey Guys -

    When the plugin is first activated, it sends a request to my server to retrieve the version numbers for the latest version of timthumb.php, and the latest one with no known security vulnerability. I'm guessing the errors you saw were related to not being able to make the connection. If it can't make the connection, the plugin defaults to the latest version when the plugin was released (2.8.2), so you should be fine for now.

    I'll look into suppressing those errors on activation for the next version.

    Thanks!

  4. jayPEG
    Member
    Posted 2 years ago #

    Sounds great. Thanks for the info!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic