WordPress.org

Ready to get started?Download WordPress

Forums

ThreeWP Broadcast
Error on broadcast post types settings page (7 posts)

  1. miraclemaker
    Member
    Posted 1 year ago #

    Just updated to version 1.12, I get lots of error messages on the page where you can choose post types to broadcast:

    Warning: array_merge() [function.array-merge]: Argument #2 is not an array in E:\...\threewp-broadcast\SD_Form.php on line 337

    Warning: array_merge() [function.array-merge]: Argument #2 is not an array in E:\...\threewp-broadcast\SD_Form.php on line 427

    etc...

    I fixed this by updating line xxx of ThreeWP_Broadcast.php:
    from:
    ' . $this->display_form_table( $input_post_types ) .'
    to:
    ' . $this->display_form_table( array($input_post_types) ) .'
    Thanks.

    http://wordpress.org/extend/plugins/threewp-broadcast/

  2. miraclemaker
    Member
    Posted 1 year ago #

    - That should have been line 421.

  3. Spinal
    Member
    Posted 1 year ago #

    I can confirm this bug and solution, using WP 3.4.2 and ThreeWP 1.12.

  4. adammontague
    Member
    Posted 1 year ago #

    Works like a charm, thanks!

  5. snaz2000
    Member
    Posted 1 year ago #

    - can anyone confirm whether this works with WP 3.5 ?
    I'm unsuccessful...

  6. graphicpoet
    Member
    Posted 1 year ago #

    Snaz2000

    NO it is completely broken on 3.5. The new media format changes the architecture of folders in a way that is mismatched with this plugins core code.... Not a biggy for the plugin creators just a task of time to bring it up to date with this new role-out of WP 3.5....HOPEFULLY...:)

  7. snaz2000
    Member
    Posted 1 year ago #

    ...it did a single push from my parent theme's Pages to subdomains (even with noted Plugin errors) ...which is what I was initially looking for ...wanted to test different themes within a subdomain that had content ...there was clean-up of those pages as you infer ...didn't look at post, comment, reply, edit between linked sites

    I'm a n00b and appreciate the response ...I'm not certain why anyone would ever upgrade WP or a theme or a plug-in ...in my short three weeks of testing, WP 3.5 has caused drag and drop tools in Admin for theme designing to break, plugins not to work, etc. ...one theme update started using different CSS IDs rendering a custom child theme's CSS useless

    I guess I need to start reading release notes... :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags