WordPress.org

Ready to get started?Download WordPress

Forums

ThreeWP Broadcast
Brodcast errors (7 posts)

  1. mthoreb
    Member
    Posted 1 year ago #

    Trying to broadcast a post from one siteto another site I get these errors and the broadcast doesn’t work. Multi site with only 8 sites.

    Warning: copy() [function.copy]: The first argument to copy() function cannot be a directory in /home/mthoreb/public_html/wp-content/plugins/threewp-broadcast/ThreeWP_Broadcast.php on line 1824

    Warning: Cannot modify header information - headers already sent by (output started at /home/mthoreb/public_html/wp-content/plugins/threewp-broadcast/ThreeWP_Broadcast.php:1824) in /home/mthoreb/public_html/wp-includes/pluggable.php on line 881

    http://wordpress.org/extend/plugins/threewp-broadcast/

  2. edward mindreantre
    Member
    Posted 1 year ago #

    Yeah... I'm gonna have to look at image broadcasting again sometime.

    *sigh*

  3. luba lee
    Member
    Posted 1 year ago #

    Same here. WordPress 3.5.1 + ThreeWP Broadcast 1.18 (I don't have latest PHP). Everything working smooth except for custom post types.

    I'm getting almost same warning as in this thread and CPT is not broadcasted:

    Warning: copy() [function.copy]: The first argument to copy() function cannot be a directory in /usr/home/apaseotravel.com/web/wp-content/plugins/threewp-broadcast/ThreeWP_Broadcast.php on line 2012

    Warning: Cannot modify header information - headers already sent by (output started at /usr/home/apaseotravel.com/web/wp-content/plugins/threewp-broadcast/ThreeWP_Broadcast.php:2012) in /usr/home/apaseotravel.com/web/wp-includes/pluggable.php on line 876

    Please, help me to get this fixed. It's a very important feature for the site I'm working on!

  4. ClaytonL
    Member
    Posted 12 months ago #

    I was having the same problem as luba, only on 3.5.2. The problem was, wp_get_attachment_metadata() was returning an empty array for the pdf attachments on our site.

    We solved it by making the following change to threewp-broadcast/AttachmentData.php:

    Change

    $metadata = wp_get_attachment_metadata($attachment_id);
    		$rv->filename_base = basename( $metadata['file']);

    to

    $metadata = wp_get_attachment_metadata($attachment_id);
    		$metadata['file']= $metadata['file'] ? $metadata['file'] : get_attached_file($attachment_id);
    		$rv->filename_base = basename( $metadata['file']);
  5. edward mindreantre
    Member
    Posted 11 months ago #

    I've already fixed this in 1.20

    I take it you're using an older version?

  6. ClaytonL
    Member
    Posted 11 months ago #

    Right, 1.18. Your PHP requirements are a bit ahead of Ubuntu's packages.

  7. edward mindreantre
    Member
    Posted 11 months ago #

    There should be repos for 5.4

    Debian7 has 5.4 as standard, though...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic