WordPress.org

Ready to get started?Download WordPress

Forums

ThreeWP Activity Monitor
Error when editing categories in quick edit (6 posts)

  1. kochanski
    Member
    Posted 2 years ago #

    Just letting you know I consistently get the following message when I update something with quick edit. I'm using v2.5 of the plugin and have just reinstalled v3.3 of WordPress.

    Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/content/72/8628872/html/wp-content/plugins/threewp-activity-monitor/ThreeWP_Activity_Monitor.php on line 1643

    http://wordpress.org/extend/plugins/threewp-activity-monitor/

  2. pixelyzed
    Member
    Posted 2 years ago #

    That happens when editing posts and pages in the regular editor as well.

  3. edward mindreantre
    Member
    Plugin Author

    Posted 2 years ago #

    Strange. Looks like the post types aren't being retrieved from the DB.

    Try editing the settings and selecting posts and pages as the post types.

  4. edward mindreantre
    Member
    Plugin Author

    Posted 2 years ago #

    How did y'all upgrade the plugin? Using WordPress internal upgrade function or ftp?

    Because deactivating and reactivating the plugin should have set a default value for the post types setting.

  5. pixelyzed
    Member
    Posted 2 years ago #

    Hi Edward,

    I believe I updated using the built-in WordPress update function but, on the site I noticed the issue first, I had deactivated the plugin. I just now reactivated it and I no longer get the error. I also visited the settings page and selected posts and pages and re-saved.

    All seems well on my end. Thanks for your reply! :)

  6. kochanski
    Member
    Posted 2 years ago #

    Thanks for the reply!

    I was on v2.3 and upgraded via WordPress automatically. I rolled back to 2.3 a few days ago and just tried the automatic upgrade again - same issue occured.

    Just went into the settings and selected posts and pages and hit Apply (after applying they didn't appear selected though?), under Activities I have the following selected (I deselected all and reselected them then applied):
    deleted_post
    password_reset
    post_publish
    post_updated
    profile_update
    retrieve_password
    trashed_post
    untrashed_post
    user_regisiter
    wp_login

    Still getting the same error.

    Deactivated the plugin and reactived, checked the plugin settings and page and post now both appear selected!

    Tested - no more error :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic