WordPress.org

Ready to get started?Download WordPress

Forums

Theme My Login
[resolved] Version 6.2 force Login page not to have a parent ? (5 posts)

  1. bluantinoo
    Member
    Posted 1 year ago #

    Hi,
    I updated This wonderful plugin to last version, but now I cannot anymore access to login/register/profile page

    I had the Theme My Login page as a subpage of another.
    So i could login just going on mysite.com/parentpage/login/

    now the login page is accessible just hardcoding URL, every link (even the "view page" in editing screen) points to mysite.com/login/ without the "parentpage" slug.
    but the page is still a child of "parentpage"

    is it normal or I'm missing something?

    http://wordpress.org/extend/plugins/theme-my-login/

  2. Jeff Farthing
    Member
    Plugin Author

    Posted 1 year ago #

    TML woudln't know whether it is a child page or not. Check that the Page ID field in the TML settings matches your page.

  3. bluantinoo
    Member
    Posted 1 year ago #

    Hi Jeff,
    the page ID field is showing the correct data, exactly as it was before upgrading TML. And that page is a subpage.

    But the links and redirects of TML seems to just ignore the parent page slug.
    I mean:
    - register link on login page
    - lost password link on login page
    - redirect after login submission on login page (that means I cannot login)
    - redirection from wp-admin/profile.php

    before upgrading TML it was ok, it was redirecting to the correct URL. And I'm sure I've not made any other changement to my wp.

    for the moment I can solve just putting the login page on the root, but I would like to solve it.

    Jeff, did you ever try putting the login page under another parent page?

  4. Jeff Farthing
    Member
    Plugin Author

    Posted 1 year ago #

    No, I have not. But I think I know why. It has to do with the new permalinks settings. I will have to come up with a workaround for 6.3 (or 6.2.1). Meanwhile, you can work around this by using the permalink settings. Just set the permalinks in the TML settings to use your structure. For instance, in the login box, you would put "{parent}/login", where parent is what the slug should be.

  5. sccr410
    Member
    Posted 1 year ago #

    I can confirm this same issue on a site as well.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic