WordPress.org

Ready to get started?Download WordPress

Forums

Theme My Login
[resolved] Password strength meter broken in 6.2.2 (5 posts)

  1. Daedalon
    Member
    Posted 1 year ago #

    In the newest Theme My Login, 6.2.2, password strength meter shows only these texts and colors:

    • On empty password: Vahvuusmittari (Strength meter), background-color: #EEEEEE;
    • On 1-3 characters or if the passwords don't match: Erittäin heikko (Very weak), background-color: #FFA0A0;
    • 4-99 characters of _any_ kind: Erittäin heikko (Very weak), background-color: #EEEEEE;

    The issues:

    1. Doesn't react to the password being made stronger in any way after the fourth character is typed. The strongest possible password still gets "Very weak" with the same background-color as the verdict in Finnish.
    2. Shows the same message, "Very weak" for passwords that don't match. On the upside, the background-color is red as it should be.

    On the similar [wpuf_editprofile] page created by WP User Frontend plugin, the password meter works as intended. Using the WPUF-generated profile page isn't an option for our site, though, as it doesn't translate automatically as TML profile page does.

    http://wordpress.org/extend/plugins/theme-my-login/

  2. Jeff Farthing
    Member
    Plugin Author

    Posted 1 year ago #

    Is it correct in English?

  3. Daedalon
    Member
    Posted 1 year ago #

    Edit: The issue seems to be linked with using WP User Frontend plugin (not WP Super Cache as I thought earlier). Just having WPUF version 1.1 enabled seems to be enough to break the password strength meter feature in TML 6.2.2.

    Offtopic: It's a good idea to have /login/\?action=profile as an exception rule in WP Super Cache settings (insert as its own line into WPSC Settings > Advanced > first text box). Not having that made testing this harder, as I kept getting cached pages despite trying out different plugin setups. It also removes the issue of users not seeing the changes after updating their profile and returning to it right after. Having enabled [X] Don’t cache pages for known users. (Recommended) also fixes the same thing.

  4. Daedalon
    Member
    Posted 1 year ago #

    Edited the previous post as I found right after that I was on a completely wrong track due to a missing backslash in the WPSC exception rule.

  5. dragondance
    Member
    Posted 1 year ago #

    I had the same problem and found this topic, it's helpful because I didn't know it was because of WP User Frontend. I managed to fix the problem, it requires modifying WP User Frontend but at least it works. I'm not sure you still need this now, but hope it can help if anyone have the same problem.

    Both plugins insert js code for the password strength indicator and conflict with each other. I want to use Theme My Login profile page, so I commented the code for password strength indicator in WP User Frontend:
    wp-user-frontend/js/wpuf.js
    line 9->11

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic