WordPress.org

Ready to get started?Download WordPress

Forums

Theme My Login
[resolved] Mini-Bug in Custom-emails.php (3 posts)

  1. Arkaitz
    Member
    Posted 3 years ago #

    Hi everyone,

    I don't know if someone is using the retrieve and reset mail option with the plugin, but if you do you would know that mail-type and from data is not filled when the mail is sent.

    I have found why the call to get the options was wrong. To solve this, in custom-email.php you have to change the next (line 78 & line 94):

    Are like this:

    78 $options =& $GLOBALS['theme_my_login']->options->get_option( 'retrieve_pass' );
    94 $options =& $GLOBALS['theme_my_login']->options->get_option( 'reset_pass' );

    They must be:

    78 $options =& $GLOBALS['theme_my_login']->options->get_option( array( 'email', 'retrieve_pass' ) );
    94$options =& $GLOBALS['theme_my_login']->options->get_option( array( 'email', 'reset_pass' ) );

    Cahnging this the options are loaded as they have to.

    I hope you will use.

    Sorry of my poor english...

  2. Jeff Farthing
    Member
    Plugin Author

    Posted 3 years ago #

    Which version are you using? This is not the case in the newest version.

  3. Arkaitz
    Member
    Posted 3 years ago #

    I'm using the previous version, because when i started the current project it was the newest, and now i cant upgrade because i have changed so many things.

    I have just posted this to inform people who may be using my version of the plugin, or directly to fix future versions.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic