WordPress.org

Ready to get started?Download WordPress

Forums

Theme My Login
Login redirect issue with bbPress (3 posts)

  1. Imokon
    Member
    Posted 1 year ago #

    I've tried to look up this particular issue in the forum so far but found nothing, so if I overlooked something I apologize.

    I downloaded TML today and am trying to use it for an installation that uses bbPress as a plugin.

    I have everything stripped barebones as much as possible:

    theme: TwentyEleven
    plugins: Akismet, BadBehavior, WP Security Scan, Theme My Login and obviously bbPress 2.1.2

    I am trying to get users who both login and logout to be redirected to:

    mydomain.com/bbpress-slug-for-main-forum-index

    Right now I have the basic tag for logging in on default page listing, I've tried it as a tag in another page also.

    On logout, users are successfully logged out to the forum index.

    On login however I go straight to my default designated static index page of my website, not the designated forum index. So I went ahead and disabled static page (back to default recent posts) and still same issue, I log in to my default recent posts.

    I was hoping to keep my forums login only so that users would have to login before seeing everything. Any ideas? I really don't want to deactivate my antispam plugins because I doubt they have anything to do with it, but if they are the issue then I really need to know because I can't give them up.

    Thanks in advance.

    http://wordpress.org/extend/plugins/theme-my-login/

  2. Jeff Farthing
    Member
    Plugin Author

    Posted 1 year ago #

    Are you using the Custom Redirection module?

  3. Imokon
    Member
    Posted 1 year ago #

    Yes, I am using the Custom Redirection module incorporated in your plugin.

    I have the default registration role set to Forum Participants in WordPress and as for your plugin role settings I have the redirects for Forum Moderators, Forums Participants, as well as default Subscribers set to the above mentioned url. I've checked this signing on as a test user with those roles.

    I've tried to tinker with it and I had this issue both before and after bbPress was embedded into a page (slug = "Forums") which is the same slug for primary bbPress settings as well.

    On a side note if you could pretty please check this other question, I hopefully placed it in the appropriate thread for you:
    http://wordpress.org/support/topic/plugin-theme-my-login-extra-fields-on-the-registration-form-website?replies=3#post-3211560

    Thanks again so much.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic