WordPress.org

Ready to get started?Download WordPress

Forums

Theme My Login
Latest Upgrade Error (5 posts)

  1. TheKdd
    Member
    Posted 3 years ago #

    Since the upgrade, no members are able to login or register via the the login link. The error is: Call to undefined function validate_username() then points to the theme my login folder.

    I deactivated the plugin, but now hitting register as guest takes me to a page that just says theme-my-login.

    For now, I have redirected all register and login requests to my forum. Any possible fix for this?

    http://wordpress.org/extend/plugins/theme-my-login/

  2. Jeff Farthing
    Member
    Plugin Author

    Posted 3 years ago #

    Sounds like it has to do with the deprecation of wp-includes/registration.php in WordPress 3.1. However, the code in the plugin tells it to load it still if the version is below 3.1. I see you're using 3.0.5, so it should still load it.

    if ( version_compare( $GLOBALS['wp_version'], '3.1', '<' ) )
    	require_once( ABSPATH . WPINC . '/registration.php' );
  3. Jeff Farthing
    Member
    Plugin Author

    Posted 3 years ago #

    Try this, create a file called theme-my-login-custom.php in your /plugins directory. Then add the following to it:

    <?php function tml_request( &$theme_my_login ) {
    	if ( 'register' == $theme_my_login->request_action )
    		require_once( ABSPATH . WPINC . '/registration.php' );
    }
    add_action( 'tml_request', 'tml_request' ); ?>

    Let me know if that resolves it.

  4. TheKdd
    Member
    Posted 3 years ago #

    Ok I threw it in, straight to the plugins folder and it still just says theme-my-login when you hit login.

    So then I tried putting it in the actual theme-my-login folder, but that was a no go as well.

    And btw, thanks for getting back to me so quickly.

  5. TheKdd
    Member
    Posted 3 years ago #

    Ok you know what... So when I re-activated the plugin, it was throwing all kinds of errors. So I de-activated, removed the new .php, reactivated, and all is well now. Go figure.

    Thanks so much for your help!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic