WordPress.org

Ready to get started?Download WordPress

Forums

Theme My Login
[resolved] Custom registration template shows "login" not "register&quo (15 posts)

  1. BenFitts
    Member
    Posted 1 year ago #

    I have setup the custom registration template as per the instructions at:
    http://www.jfarthing.com/development/theme-my-login/templates/

    Unfortunately it shows me a "login" form and not a "register" form. It appears to be a problem with the code within /theme-my-login/templates/register-form.php

    I have turned off all plugins except "theme my login".

    I copy your templates/register-form.php file into my themes folder. I create a new registration page and add the shortcode to my new page.

    However when I go to view my new page (not logged in) I get a "login" form every time.

    I should see a "registration" form there instead.

    http://wordpress.org/extend/plugins/theme-my-login/

  2. Jeff Farthing
    Member
    Plugin Author

    Posted 1 year ago #

    I think you misunderstand how the custom templates work. There's no need to create a new page with the shortcode. If you kept the default name for your template (register-form.php), it will be used when the action is register.

  3. BenFitts
    Member
    Posted 1 year ago #

    Actually i want to setup 2 different user registrations. That is why I wanted to make a copy. I had one using the regular wordpress registration and one that has some extra fields.

  4. Jeff Farthing
    Member
    Plugin Author

    Posted 1 year ago #

    So, if you're setting up a custom register page, you would need to name the template differently, otherwise it will be used for the regular registration. You also need to set the default action:

    [theme-my-login default_action="register" register_template="my-register-form.php"]

  5. BenFitts
    Member
    Posted 1 year ago #

    Right. That was my understanding when reading the docs and I have done all that.

    [theme-my-login default_action="register" register_template="wholesale-register-form.php"]

    copied register-form.php to my theme folder and renamed it wholesale-register-form.php

    The problem is that a login form with login submit button is showing, not a registration form. Regardless of my custom fields (I took them out to debug and test a generic registration.)

    Do I need to change something else too?

  6. des1001
    Member
    Posted 1 year ago #

    I have the same problem as BenFitts. It loads login page instead of registration.

    Rest works like a charm.

  7. Jeff Farthing
    Member
    Plugin Author

    Posted 1 year ago #

    Nope. That should be it. Can I see your site?

  8. pietdeziek
    Member
    Posted 1 year ago #

    So am I, do you find any solution?

    It loads login page instead of registration.
    Rest works like a charm.

  9. Ferenc Vasóczki
    Member
    Posted 1 year ago #

    Have same problem.

    Intresting, because i checkcked the previous version, and there it worked.
    Maybe i'll see through the changings.

    Anyway, i dedicated a register page also, and when i submit this:
    xxxxxx.com/register/

    it is redirect me to:
    /login/?action=register

    Intresting.

  10. Jeff Farthing
    Member
    Plugin Author

    Posted 1 year ago #

    As of TML 6.2.3, you can specify custom permalinks per each action. What's the need to create an actual page?

  11. Daedalon
    Member
    Posted 1 year ago #

    To do that, "specify custom permalinks per each action", I found this in the documentation and opened a support thread for improving it even further: Changing Action Links

    In the meanwhile it's probably worth it to have one of the questions answered here too for the benefit of all seeking the same answer (please pardon me for repeating some points from my previous messages):

    How to make eg. the profile page be found at a certain URL? The above link lets you decide which URL the action links point to, but it then needs the additional step of having the intended page existing at that location.

    I would have guessed that the settings at /wp-admin/options-general.php?page=theme-my-login > Permalinks would have done that, but apparently they also do only the same as the above, only changing what the action links point to.

    That'd be fine, especially if the settings page would mention that a) that is what the setting does (doing which I can warmly recommend :)) and b) that to have a responding page at the target there's an extra step to be done (which the documentation would also link to). I'd guess the extra step is easiest done by creating a page with a shortcode, but I'm having a trouble getting that working as I think others in this thread are experiencing as well.

    Maybe post in http://www.jfarthing.com/development/theme-my-login/shortcode/ a few most-wanted examples like how to create a basic profile page shortcode and a register page shortcode with a few extra options? That'd be neat.

    Thanks for Jeff in advance!

  12. BenFitts
    Member
    Posted 1 year ago #

    In my scenario I was using "Theme my login" to create multiple registration pages. We had one which had extra fields. I didn't want all the extra fields to show up on the default registration form.

    Unless I'm mistaken, the solution of permalinks won't help with registration pages.

  13. bullapipen
    Member
    Posted 1 year ago #

    Hi BenFitts, I'm trying to accomplish the same thing, did you find a solution yet?.
    If you do, can you past it when you find it? I will do the same thing if I find one.
    Thanks

  14. chandravanshi
    Member
    Posted 1 year ago #

    I guess when you use the shortcode for registration in one of your pages and if you have specified the page-id of the same page in
    settings-> general, (which should be the page id of login page) your shortcode for registration won't work. It will show you the login-form instead.

  15. jasonkadlec
    Member
    Posted 1 year ago #

    I got this to work by:

    <?php theme_my_login( array( 'default_action' => 'register' ) ); ?>

    But I'm guessing via shortcode will work to.

    Problem: Action says default to the registration, but the user always sees the login.

    Solution: Visit the permalinks page of your settings to flush the permalink rules

    Reload page -- see it working as expected.

    I also happened to try changing the page ID --- so if the above doesn't work for you, you can follow all the steps I had:

    Step 1 -- go to settings, find the page id, change it from the default set there to the page ID of where I'm trying to load <?php theme_my_login( array( 'default_action' => 'register' ) ); ?> -- but having no love.

    Step 2 -- save that new page ID, go to that page, reload, see it's still defaulting to the login.

    Step 3 -- go back to the settings, put back the original page ID that had been defaulted.

    Step 4 -- go to view permalinks page in your settings...

    But I'm guessing step 4 is all you need.... I've done a lot with custom post types and once spent I think a whole day before I realized you just need to visit that permalinks page to flush the rewrite rules -- so that's what I figured must be going wrong here... and for me it was.

    ENJOY

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic