WordPress.org

Ready to get started?Download WordPress

Forums

Theme My Login
6.2 - Can't get anything to work right anymore (7 posts)

  1. sccr410
    Member
    Posted 1 year ago #

    So I recently upgraded to the latest version and unfortunately it seems things are broken. I'm not entirely even sure how to describe it. It "works", but not really. I guess it just doesn't work how it used to and the new functionality makes it useless.

    We had our account page on a child page. It kept trying to redirect the page to the root URL.

    Actual account URL: http://www.domain.com/distributors/account
    Redirected to URL: http://www.domain.com/account (resulted in 404)

    I found a thread that talked about manually editing the permalinks and that did seem to fix this issue - although this shouldn't be required in the first place.

    Then, previously, we had the Account page (or Profile edit page) listed via wp_list_pages since it is just a regular WP page. It appeared fine in our sidebar where we list all sub pages. With the new plugin it removed it. I then found the option for "Show page in page list" thinking that was it. But when logged in, now it shows a logout link. As a result there is no way to link to the Profile page for users to edit their info.

    I disabled all plugins except TML and still this link to the Profile page would not appear. Reverted back to the previous version of TML and still wouldn't appear. So I added a new page to act as the TML profile page, added the shortcode, changed the page ID in the settings. This new page didn't show, but now the old page did. Linking to the old page showed 3 links for Dashboard, Profile, Logout - I want it to go directly to the profile page!

    What the heck is going on?!

    http://wordpress.org/extend/plugins/theme-my-login/

  2. Jeff Farthing
    Member
    Plugin Author

    Posted 1 year ago #

    The child page issue has already been brought to my attention. As I (and you) mentioned, it can be fixed by setting the TML Permalinks accodringly.

    As far as the page links, TML 6.1.4 also changed the Login link to Logout within wp_list_pages().

    P.S. Your title is a bit vague and misleading.

  3. sccr410
    Member
    Posted 1 year ago #

    You're right, it is misleading - sorry, can't change it now.

    My main issue is that wp_list_pages no longer shows the page associated with TML. I need that to happen. How do we make that happen? Why is it removed in the first place?

  4. Jeff Farthing
    Member
    Plugin Author

    Posted 1 year ago #

    But it does show. The only reason it wouldn't show is:

    1. You have the option Show In Pagelist unchecked
    2. You're actually using wp_nav_menu()
  5. jacobdubail
    Member
    Posted 1 year ago #

    Hey Jeff,

    You mention manually changing the permalinks. What do you mean by this? I'm getting a 404 error now as my login page is a child page.

    Thanks,
    Jacob

  6. sccr410
    Member
    Posted 1 year ago #

    I have Show In Pagelist checked - http://screencast.com/t/LzY0cDTWYR4

    I don't use wp_nav_menu, I use wp_list_pages - http://screencast.com/t/IvqOZKWd ($root_parent_id is a variable that gets the top most parent of the current page and is set earlier in the template file)

    My page structure is here - http://screencast.com/t/GDoS1wxOk

    I get this sub menu - http://screencast.com/t/6l7Ky7wgNF8 (notice it shows "Logout" instead if "Account" with a link to the profile page)

    My Account page has the TML shortcode - http://screencast.com/t/5lHmRdv3bu

    Where it says "Logout", that should be a link to the user's profile page. This worked previously (I don't know what version of the plugin I had) but now it goes to a logout link which makes absolutely no sense to me.

  7. Altamami
    Member
    Posted 1 year ago #

    I'm having the same issue as jacobdubail. I also opened a thread explaining the problem: http://wordpress.org/support/topic/plugin-theme-my-login-widget-redirects-to-404-error?replies=1

    I would really know how to fix this problem. It seems it can be done using the permalinks, but I do not know how.

    sccr410, a link to the thread that talks about the fix you mentioned would be of great help.

    Regards,
    Altamami

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic