WordPress.org

Ready to get started?Download WordPress

Forums

Theme-Check
[resolved] Wrong message? "REQUIRED: add_theme_support( custom-background )" (5 posts)

  1. Gabriel Reguly
    Member
    Posted 2 years ago #

    When checking a theme I get this error message:

    REQUIRED: add_theme_support( custom-background ) was found in the file functions.php. Use add_custom_background() instead.

    But looking at
    http://codex.wordpress.org/Function_Reference/add_theme_support the information is the opposite.

    I wonder which one is correct?

    Cheers,
    Gabriel

    http://wordpress.org/extend/plugins/theme-check/

  2. Gabriel Reguly
    Member
    Posted 2 years ago #

    Oh dear.

    The documentation clearly states that this is for 3.4 and I am using 3.3.2 :-(

    Sorry for the false alarm.

    Cheers,
    Gabriel

  3. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 2 years ago #

    Theme check hasn't updated to 3.4 yet, so yeah, some of the details changed along the way there.

  4. Gabriel Reguly
    Member
    Posted 2 years ago #

    Thanks for the answer Otto.

    An unrelated issue, but since I got your attention I'll take advantage of it :-)

    There is a plugin, Register Plus Redux, which was removed from the repository.

    Unfortunately the plugin author does not know what to do in order to fix the issue.

    http://radiok.info/blog/where-redux-went/#comments

    I know this should be addressed to plugins@wordpress.org, so sorry for abusing this comment form.

    Gabriel

  5. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 2 years ago #

    Unfortunately the plugin author does not know what to do in order to fix the issue.

    You answered your own question. He should email plugins@wordpress.org and ask there.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic