WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: The Events Calendar] Set time issue v1.5.4 (12 posts)

  1. GPro
    Member
    Posted 4 years ago #

    Just updated to 1.5.4, looks good except when I add a new event, regardless if I choose am or pm it posts as am.

    Is this a bug or am I doing something wrong.

    Thanks for any help, have a good vacation!

    GPro

  2. jakobmichaelis
    Member
    Posted 4 years ago #

    I am also having this issue. I recently updated to 1.5.4 and, like OP, the event defaults to AM upon adding the event or updating. Pretty sure it's a bug.

    I've just entered about 75 events and just caught this. FML

  3. Shane Pearlman
    Modern Tribe
    Posted 4 years ago #

    thanks folks - we'll fix it and a couple other small bugs being reported and do a 1.5.5 next week.

  4. justinendler
    Member
    Posted 4 years ago #

    This is now fixed in trunk and will be released with 1.5.5

    There are two options till then: Grab the-events-calendar.php from trunk and replace your version of that file:

    http://plugins.svn.wordpress.org/the-events-calendar/trunk/the-events-calendar.php

    OR

    fix the couple lines yourself, the problem is in the method dateToTimeStamp(). You could search for that and replace your version of the method with trunk's.

    Hit the forum up if you can't get it to work.

    Thanks for reporting. Good catch.

    Justin

  5. jakobmichaelis
    Member
    Posted 4 years ago #

    Justin,

    That fixed it. Thank you for your quick response and fix. I just updated the lines myself and it worked no problem.

  6. GPro
    Member
    Posted 4 years ago #

    Fixed for me too.

    Thanks Justin

    GPro

  7. davehapawordpress
    Member
    Posted 4 years ago #

    Fixed for me. Thanks.

  8. mikeyleung.ca
    Member
    Posted 4 years ago #

    Hi guys,

    I switched my WordPress to 24-hour time format (H:i) and then it seemed to accept the time afterwards.

    -M

  9. OnlyTono
    Member
    Posted 4 years ago #

    I had the same issue,
    I was able to fix it by simply changing the Time Format under the:
    Settings->General menu to use an UPPERcase AM/PM.

    use this: 1:46 PM
    not this: 1:46 pm

    Hope that helps someone until the fix is out

  10. CHM82
    Member
    Posted 4 years ago #

    When choosing H:i time format (24h).. There is no option to choose the midnight time.. 24:00 or 00:00. How can I fix this?

  11. Don Elliott
    Member
    Posted 4 years ago #

    00:00 is midnight.

  12. Anonymous
    Unregistered
    Posted 4 years ago #

    Ditto, there is no setting midnight.

    The hour 00 doesn't exist, neither does 24, thus no way to set a time between midnight and 1am.

    This is really perturbing when the usual closing time to list is midnight. Closest we can get is 23:55 and that's just a cheap "ugly" workaround.

    Any thoughts on how to correct this would be very much appreciated.

Topic Closed

This topic has been closed to new replies.

About this Topic