WordPress.org

Ready to get started?Download WordPress

Forums

The Events Calendar
[resolved] Navigation from Template get lost! (44 posts)

  1. svenulrich
    Member
    Posted 2 years ago #

    I'am using the EventsCalendar, placed in the navigation by a simple link. By click on the link the navigation of the Template (Showcase, by Freshface) get lost. What can i do! And who knows how i can place the calendar by a simple shortcut on a single page.

    You'll find it here

    Thanks for answers!

    http://wordpress.org/extend/plugins/the-events-calendar/

  2. marv8877
    Member
    Posted 2 years ago #

    I have the same problem. My menu has gone, my backgroundslider does not work and the calendar works no longer in Full Width.

    LINK to the Page

    Thanks for the help...

  3. teddyedward
    Member
    Posted 2 years ago #

    Similar problem here. Love your product but can't use it if my client is unable to navigate away from the page.

    Link Here

  4. roblagatta
    Modern Tribe Support
    Plugin Author

    Posted 2 years ago #

    Hi there guys. Thanks for reaching out on this main issue on the navigation getting lost; I'm not sure what the problem is myself, but as all 3 of you have reported it (and I saw another thread just a moment ago) it does seem like there must be some common factor. It's likely something in the theme but let me see if our dev Jonah can identify a common theme that we might be able to offer some guidance on. Stay tuned and I'll have him comment directly if so.

    To svenulrich's question: the plugin does not use shortcodes, but has template tags which serve a similar purpose. You can check those out at http://tri.be/support/documentation.

    marv8877: the backgroundslider issue sounds like a separate problem, right? Is that controlling the menu or unrelated?

  5. Bruce
    Member
    Posted 2 years ago #

    I have the same problem -- plain vanilla installation with default WP theme. Latest version of WP 3.4.1

    Header area and navigation bar do not appear on the Events page:

  6. svenulrich
    Member
    Posted 2 years ago #

    I changed the Permlink-structure and it works better. Navigation is there, but no h1 Headline from the template.

  7. tomatom
    Member
    Posted 2 years ago #

    I have exactly the same problem for a site I'mhelping out with.

    The Navigation bar has disappeared on the events page and calendar pages.

    http://www.lezzet.com.au/online/?post_type=tribe_events

    The single event page is fine:

    http://www.lezzet.com.au/online/?tribe_events=bread/

    Any help getting the Nav bar back would be great.

  8. Nicholas
    Member
    Posted 2 years ago #

    Hi!

    I have the same issue here. WP 3.4.1. Live Wire (Hybrid Core) child theme. No navigation on list and calendar view. Also seems to disrupt my query_posts calls.

    Navigation does appear on single event page, and query_posts working as normal.

    Seems to be related to WP 3.4.1 update, since I have a site running the plugin on 3.4 that still works great!

  9. xanda88
    Member
    Posted 2 years ago #

    Hi, I have the same problem when using this plugin with the Sterling theme. Any leads?? Could it have something to do with post_type?

  10. ajsonnick1
    Member
    Posted 2 years ago #

    Having the same issue... Did anyone find a fix??

  11. ajsonnick1
    Member
    Posted 2 years ago #

    FIXED THE ISSUE *TEMPORARILY*... Version 2.0.7 of THE EVENTS CALENDAR doesn't fully work evidently.. downgraded to 2.0.5 works like a charm! (nav wise)

  12. MajorROM
    Member
    Posted 2 years ago #

    Check your URL/link to the calendar. With the right permalink it works.

  13. Bruce
    Member
    Posted 2 years ago #

    Thanks, that fixed it for me.

  14. roblagatta
    Modern Tribe Support
    Plugin Author

    Posted 2 years ago #

    Glad to hear the 2.0.5 downgrade is working for you folks. We do have 2.0.8 coming out today or tomorrow, and I'd be interested to hear whether it works as a fix for those of you still having problems and for whom the permalink tweak doesn't do anything. As Ramon noted, though, turning on permalinks and using a structure like /%postname%/ would probably be a better starting point.

    Thanks to everyone for their patience on this. If folks still have issues after updating let us know and we'll keep trying to work out the integration with your specific theme from there.

  15. venkmanuk
    Member
    Posted 2 years ago #

    Hi - i have the same disappearing menu problem i think.

    i'd started my own thread but rob pointed me over to this thread to keep it contained.

    <?php wp_nav_menu( $defaults ); ?> would work OK but wp_nav_menu( array( )); items would break it. For now i fixed it with an if/else hack and a hard coded menu - which isn't ideal.

    ~ i'll take Ramon Kaes advice and check the url.. and i'm more inclined to wait for the new 2.0.8 release than downgrading to an old version.

    thanks roblagatta! ^_^

  16. JustDuckyDesigns
    Member
    Posted 2 years ago #

    I just posted on another thread, before seeing this one. I'm having the same issue and more:

    I am using "The Event Calendar" - in the settings, under "General" I have selected "Calendar" from the "Default view for the Events" option. But when I view the page it shows it in "Event List" mode. No matter which option I choose, it shows "Event List" rather than "Calendar".

    Does anyone have a fix for this?

    Also, I my navigation menu does not show on the Events page or on the detail events page - it works fine on every other page.

  17. venkmanuk
    Member
    Posted 2 years ago #

    yeah dude the 'fix' for that is to log out and look at it. it displays correctly for visitors.

  18. JustDuckyDesigns
    Member
    Posted 2 years ago #

    I tried logging out - that doesn't change anything.

  19. venkmanuk
    Member
    Posted 2 years ago #

    hmm, sorry - that was the fix for me.
    it's definitely a separate issue form missing navigation anyway.

  20. lee718
    Member
    Posted 2 years ago #

    Same issue here, any fixes yet. I'm using it with twentyeleven and everything is working great except that my top nav disappears on the calendar/events list page.

    @Ramon Kaes, @Bruce...What exactly was the fix that worked concerning the url?

    Thanks

  21. lee718
    Member
    Posted 2 years ago #

    I fixed it by using permalinks. If you've got default permalinks, it will not allow the nav to show on events page.

  22. roblagatta
    Modern Tribe Support
    Plugin Author

    Posted 2 years ago #

    hey guys: been a few days since I checked this thread but wanted to jump back in and see how things were going. Did the 2.0.8 update resolve this for any of you folks?

    Sounds like venkmanuk, lee718...you guys are both set here? Let me know if not. Otherwise, JustDucky, let me know if you had luck with 2.0.8 or we can keep troubleshooting as needed.

  23. pommeco
    Member
    Posted 2 years ago #

    Dev Team -- We are using the 2.0.8 version The Events Calendar for two WordPress sites. Both use twenty-eleven with child themes. In one case, we used an older version of The Events Calendar in order to resolve. I'd like to use newest version 2.0.8., but though this is installed, it continues to show behavior noted above. The main navigation bar disappears for the calendar screen view, but returns for the single event screen view. The site is here. It's in development, but again, I'd like to resolve this before we release it to the users. If necessary, I'll revert to an older version of The Events Calendar.

  24. jayharty
    Member
    Posted 2 years ago #

    The permalinks fix my problem too.

  25. UNITXT
    Member
    Posted 2 years ago #

    Only changue the permalinks structure and fix the problem.

    After changue the permalink go to calendar-event /settings / and click on "Where's my calendar?" and get the new link

  26. venkmanuk
    Member
    Posted 2 years ago #

    Thanks UNITXT!

    OK.
    My permalinks were already set to 'Day and name' - No menu.
    I upgraded the Calendar to the latest version. No change.

    Here's what was wrong!
    My links to the calendar were like this:
    <?php echo site_url(); ?>?post_type=tribe_events&eventDisplay=month
    They should be like this:
    <?php echo site_url(); ?>/events/

    So in English, go to Settings/Permalinks and ensure Common Settings is set to something other than 'Default' then go to Events/Settings and use the link displayed under "Where's my calendar?" ..

    Thanks all!

  27. roblagatta
    Modern Tribe Support
    Plugin Author

    Posted 2 years ago #

    Thanks a lot, UNITXT! Really appreciate your support in helping another user out here. Glad to hear, venkmanuk, that you're now where you need to be. Your explanation will be of use to anyone else who comes in down the road with this same issue.

    Only other person I'm seeing on this thread who may not be squared away is pommeco; can you confirm whether you're still having issues here and we can try to troubleshoot as needed? Cheers!

  28. jcdfc
    Member
    Posted 1 year ago #

    I followed the directions venkmanuk gave, but I'm not sure I did it exactly right as I couldn't find "Where's my calendar" under the calendar settings. I changed the permalinks to the post name and then tried redirecting the calendar page, but my calendar page still does not allow users to navigate using the top menu.

    Any ideas?

    thanks!

  29. venkmanuk
    Member
    Posted 1 year ago #

    here's a screenshot of where there 'where's my calendar' link is...
    http://cl.ly/image/3a1N1K3N2y0q

    hope you get it sorted.

  30. jcdfc
    Member
    Posted 1 year ago #

    Updated the plugin and your directions helped! Thanks a million :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic