WordPress.org

Ready to get started?Download WordPress

Forums

The Events Calendar
[resolved] Navigation from Template get lost! (44 posts)

  1. roblagatta
    Modern Tribe Support
    Plugin Author

    Posted 1 year ago #

    Excellent! It sounds like we're all set here, and I really appreciate you guys helping each other out to get this squared away. Since we haven't heard from pommeco in a while and everyone else (including the original author) seems to be sorted, I'm going to mark this thread RESOLVED. Please do let us know if anyone encounters any further issues on this front and thanks to everyone for their patience so far.

  2. tobyyoung
    Member
    Posted 1 year ago #

    Just installed the latest version... have the issue where when on the events page main menu does not work... see here I have permlinks set to post title... and The menu item is pointing directly to the "where is my calendar link"... still stuck? Any ideas...

  3. JamesBurke
    Member
    Posted 1 year ago #

    I'm also still having this issue.

    We had to turn permalinks off for an unrelated bug, but now our menu disappears just like everyone else. We're up to date on plugin + WP install.

  4. roblagatta
    Modern Tribe Support
    Plugin Author

    Posted 1 year ago #

    Hey guys. Thanks for the notes here; is it possible that this relates to the fact that Events-specific settings got reset upon updating? (This is a known issue we're working to patch for the next release). Can you check that / recreate your settings from before the update as needed, and let me know if the issue persists?

  5. JamesBurke
    Member
    Posted 1 year ago #

    Still not having luck after messing around with settings. Been trying to trace the issue, but haven't had any luck.

  6. bazookaman
    Member
    Posted 1 year ago #

    I just installed the plugin and have my permalinks set to postname and my menu disappears like everyone elses.

  7. roblagatta
    Modern Tribe Support
    Plugin Author

    Posted 1 year ago #

    Alright, thanks guys. The issue on tobyyoung's site seems to be fixed already, best I can tell; would either James or Bazookaman be willing to share a link to their site so I can see this problem in action and try to troubleshoot as needed?

  8. JamesBurke
    Member
    Posted 1 year ago #

    You can see ours at,

    http://www4.esu.edu/insider/
    and
    http://www4.esu.edu/insider/?post_type=tribe_events

    I took a cue from one of the others and 'faked' a primary navigation (hard coded), but you can see the issue with the secondary navigation directly below it (visible on the homepage, not on the events calendar).

    Thanks.

  9. tobyyoung
    Member
    Posted 1 year ago #

    I managed to fix by changing the template (Event->Settings->Template) to "Default Page Template" instead of the "Default Events Template"... That seemed to do the trick

    cheers

    toby

  10. roblagatta
    Modern Tribe Support
    Plugin Author

    Posted 1 year ago #

    Glad to hear that solution worked for you, tobyyoung. Thanks for confirming as much.

    JamesBurke: I think, if the template change solution doesn't work for you, the issue is unfortunately going to persist as long as permalinks are disabled. We're working to fix that issue for the 3.0 release (so that disabled permalinks work identical to pretty permalinks) but that's sadly still a couple months out. Sorry I couldn't offer up more on that end.

  11. yingwee
    Member
    Posted 1 year ago #

    Hi,
    I also tried out version 2.0.9 with the default permalink structure, WordPress 3.4.2, using the Max Magazine theme, and had the same issues that the navigation menu was missing on both the events calendar and events list pages.

    It was not an option for me to alter the permalink structure of the site. I tried all three Events templates that were supplied with the plugin (Settings | The Event Calendar | Template | Events Template) and all had the same issue.

    I checked the source of the web pages and indeed the HTML code does not include the navigation menu - other threads suggest that the menus might be hidden and could be fixed by changing the spacing around the menu in theme or altering a CSS template.

    The solution for me was to use an older version 2.0.5, which I downloaded from the wordpress web site by guessing the URL. I could not find a direct link or archive to previous versions.

    For users contemplating this path, the differences between v2.0.5 and the present version v2.0.9 looks like that the menus for the plugin are organized differently, the help within the plugin (Settings | The Event Calendar) is not as good as v2.0.9. Otherwise the functionality seems the same.

    So it looks like something got broken between v2.0.5 and v2.0.9.

    The other issues that I had were:

    • When viewing the event detail, if a feature image was inserted, images following it (such as from would be wrapped around the feature image, such as those from the WordPress Sociable plugin.
    • When entering the start and end dates for a new event, the fly-out calendar only had the dates up to the current date highlighted and it was not possible to select a date into the future, only the past(?). The solution is to manually type in the date in the numerical date box.

    Thanks guys.

  12. roblagatta
    Modern Tribe Support
    Plugin Author

    Posted 1 year ago #

    Glad to hear you got this sorted with 2.0.5, ylingwee...not an ideal solution but if it works for you that's great. The good news is that with the substantial upgrades we've made to the plugin for 3.0 this should become a moot issue across the board upon its release. Thanks to everyone still having problems for their patience so far.

  13. digorange
    Member
    Posted 1 year ago #

    I have the same problem with the nav disapperaring link is here: http://jenniferswain.com/cchhm/?post_type=tribe_events

    When I click on calendar or list it shows up though??? so why not on arrival?? I did the prettypermalinks link and still not working.

    Also I want it to open on the CALENDAR not the list view... I checked the radio btn in the settings for CALENDAR and it still opens in list view??

  14. roblagatta
    Modern Tribe Support
    Plugin Author

    Posted 1 year ago #

    Hey digorange. Thanks for the note here; mind posting this as a new thread, rather than keeping the original one (which is already rather bloated at this point) alive? If we start fresh here it'd help keep things organized. Thanks in advance!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic