WordPress.org

Ready to get started?Download WordPress

Forums

The Events Calendar
[resolved] Malformed URL results in 404 error with WP pretty permalinks (4 posts)

  1. John Gardner
    Member
    Posted 3 years ago #

    Hi,

    Either I'm doing something wrong (most likely), or there's a bug in how the URL's are processed when using the combo-box navigation.

    When using text navigation, my monthly calendar shows fine. When using combo box navigation, I receive 404 errors.

    • I've verified this with the TwentyTen theme, and disabling all other plugins.
    • Tested with any WP permalink structure except for "Default"
    • Pretty permalnks in the plugin itself is disabled

    When using the text navigation <- May 2011 / July 2011 ->, the format of the URL is as follows domain.com/category/events/?eventDate=2011-07&eventDisplay=month
    When using the combo box navigation, the order of the parameters is altered, and I believe that's where the problem lies. Note the following URL when using the combo box navigation domain.com/category/events/&eventDisplay=month&eventDate=2011-08
    If you notice, not only is the order of parameters different (which ultimately isn't a dealbreaker), but the first character following the category is an ampersand, whereas when using the text navigation it's a question mark. If I change the ampersand to a question mark in the latter example, a 404 error is not returned and I see the large calendar I'm expecting.

    Any suggestions?

    http://wordpress.org/extend/plugins/the-events-calendar/

  2. tugbucket
    Member
    Posted 3 years ago #

    On line 7 of datepicker.php it shows:

    if( '' == get_option('permalink_structure') || 'off' == eventsGetOptionValue('useRewriteRules','on') ) {
    	$link .= '&eventDisplay=month&eventDate=';
    }

    change it to:

    if( '' == get_option('permalink_structure') || 'off' == eventsGetOptionValue('useRewriteRules','on') ) {
    	$link .= '?eventDisplay=month&eventDate=';
    }
  3. maxgoldberg
    Member
    Posted 3 years ago #

    That worked for me. Thanks, tugbucket.

  4. John Gardner
    Member
    Posted 3 years ago #

    Thanks tugbucket... worked like a charm

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic