WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: The Events Calendar] Issues with Duotive Template (3 posts)

  1. pastandpresents
    Member
    Posted 2 years ago #

    Hi there, first plugin issue so apologies if I stepped on any rules.

    I'm running a pro wrestling and podcast website called http://www.theringcrewshow.com/ we are planning to launch a new section for Independent wrestling news and events and for event postings we decided to go with The Events Calendar for the plugin. Aside from a few minor layout issues the plugin is perfect for what we need. We currently have the calendar located at http://www.theringcrewshow.com/events/

    The big issue I'm having with it is in the dashboard. When clicking Events, it only displays the date of the posts. Clicking Screen Options pops up an error, "Warning: Invalid argument supplied for foreach() in /home/lonerogu/public_html/ringcrew/wp-content/plugins/the-events-calendar/lib/tribe-admin-events-list.class.php on line 169". I did some quick troubleshooting with Rob of Tri.be on the issue and we were able to verify that it is indeed my template Duotive causing the issue. Shutting off plugins does not change anything but switching to the Twentyeleven template allows the calendar to work properly and for posts in the events to display in the dashboard.

    This is a paid template so it's really important for me to get this working with the plugin. So far it's a perfect match and we just need to get the scripting working. Rob from tri.be suggested I post here so the dev can assist. Any and all help from everyone would be greatly appreciated.

    Thanks!

    Links
    duotive: http://themeforest.net/user/duotive
    The Events Calendar: http://wordpress.org/extend/plugins/the-events-calendar/

  2. Joey Kudish
    Member
    Posted 2 years ago #

    Hi pastandpresents,

    I am one of the lead developers on The Events Calendar. Thanks for choosing and using our plugin & sorry to hear that you are having issues with it.

    I haven't tested the theme you are using with our plugin, so what I am about to say is only my best guess, but I believe it should resolve your issue.

    The Duotive theme modifies the administration of WordPress heavily, and it appears to break certain WordPress native functionality. In this case, it seems like the custom columns we use in the admin for displaying event start/end dates and other event information will not be compatible with your theme.

    I've patched our code so that at the very least it no longer displays the error you were previously seeing. If you are interested in what I did, I simply made sure the foreach loop used to generate the columns is always passed an array, even if that array is empty.

    As mentioned, this incompatibility is due to functions in your theme. It may be worthwhile for you to get in touch with the theme author to let them know of the problem as well. At the very least, you should still be able to use the plugin just fine, you just won't have those columns in the event admin listings.

    We just released version 2.0.6 of The Events Calendar plugin. Unfortunately, the patch I just made for this did not make into that release, so it will have to wait a few weeks until we release 2.0.7. We don't want everyone to be able to access pre-release versions, so I won't post the pre-release code here. If you contact rob again, at pro [at] tri.be, and mention this thread, he can get you a copy of 2.0.7-alpha code, that you will be able to use until we release 2.0.7. Once we do, you will be able to auto-update as with any other version.

    Hope that answers the question and let me know if there's anything else I can do.

    Cheers
    Joey

  3. pastandpresents
    Member
    Posted 2 years ago #

    Thanks Joey!

Topic Closed

This topic has been closed to new replies.

About this Topic