WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: The Events Calendar] Incompatible with WPML? (7 posts)

  1. reblevins
    Member
    Posted 4 years ago #

    I just tried activating The Events Calendar plugin on my local WordPress MU install where I also have the WPML Multilingual CMS plugin activated and got this error:

    Fatal error: Cannot redeclare xml2array() (previously declared in /Users/.../Sites/wordpress-szd/wp-content/plugins/sitepress-multilingual-cms/lib/xml2array.php:4) in /Users/.../Sites/wordpress-szd/wp-content/plugins/the-events-calendar/the-events-calendar.php on line 1831

    I did a Google search and didn't find this error being reported anywhere else, so I'm wondering what is going on here. Is there a way around this?

  2. justinendler
    Member
    Posted 4 years ago #

    Howdy,

    Thanks for reporting the error! I need to do some snooping around in WPML Multilingual CMS and then I'll get back to you.

    Justin

  3. justinendler
    Member
    Posted 4 years ago #

    Hello again,

    Our function name xml2array() is too generic and is conflicting with your other plugin. My fix for this will appear in the next release. In the meantime, if you're comfortable doing some file switching, you can grab the fixed file from the svn repository.

    http://plugins.svn.wordpress.org/the-events-calendar/trunk/the-events-calendar.php

    Just replace your current the-events-calendar.php with the one referenced above.

    If you're running both The Events Calendar and Eventbrite for the Events Calendar, you should just replace all the files from both plugins with these repository versions of the files.

    http://plugins.svn.wordpress.org/the-events-calendar/trunk/
    http://plugins.svn.wordpress.org/eventbrite-for-the-events-calendar/trunk/

    Make sense? If this is out of your comfort zone, let me know and I'll post some more detail.

    Let me know how it works out. Thanks for pointing out the bug!

    Justin

  4. dneaster3
    Member
    Posted 4 years ago #

    Your support response time is incredible. Keep up the good work!

    I had the same conflict issue as the OP, and the the subversion download seems to be working except now I get the following error on the calendar page in "Grid View"

    Warning: Missing argument 1 for get_events(), called in D:\xampplite\htdocs\whyhopeworks\wp-content\plugins\the-events-calendar\the-events-calendar.php on line 1181 and defined in D:\xampplite\htdocs\whyhopeworks\wp-content\plugins\the-events-calendar\the-events-calendar.php on line 1552

    And in "List View" nothing shows up at all.

    Is this a related symptom or have I found something else entirely?

  5. joshology
    Member
    Posted 4 years ago #

    I am trying to install this plugin as well and I got the following error:

    Parse error: syntax error, unexpected T_CONST, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /homepages/29/d108109476/htdocs/CollideHS_WP/wp-content/plugins/the-events-calendar/the-events-calendar.php on line 13

    I am using WP 2.9.1, the Suffusion theme and I have 3 other plugins active:
    All in One SEO Pack
    Google Voice Widget Plugin
    WP Easy Uploader

    Any help would be very appreciated. The plugin looks promising. -Josh

    Oops. I found a better thread to ask this question on... sorry for the double post, but it sounds like this is another issue. I am going to post my question here: http://wordpress.org/support/topic/354560?replies=4

  6. justinendler
    Member
    Posted 4 years ago #

    @dneaster3

    Updating my code to fix this bug I've noticed someone has beat me to it, so it looks like if you try the subversion trunk of the-events-calendar.php again, you should be good. Thanks for your patience with the latest trunk, which, as you probably know, represents the newest stuff with little QA testing. Also, thanks for reporting.

  7. rscano
    Member
    Posted 4 years ago #

    Hi, would be great to have compatibility with WPML, so when a different language is added, also the content of the event will cloned in the new language.

Topic Closed

This topic has been closed to new replies.

About this Topic