WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: The Events Calendar] Fatal Error on plugin installation (8 posts)

  1. joseamo
    Member
    Posted 4 years ago #

    Hello to all,

    I have downloaded version 1.5.6 of the plugin on which I am quite insterested to try since has many features on which I would like to implement.
    When I activate this plugin it shows this message:

    Parse error: syntax error, unexpected T_CONST, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /var/www/vhosts/mydomain.com/httpdocs/wp-content/plugins/the-events-calendar/the-events-calendar.php on line 15

    I am using php 4 in my server, I also have unpluged the php safe mode just in case it could be the cause, but it is not working at all.

    If someone has suffered a similar problem I would be so thankful to get any hint about it.

    Thank you in advance

    Jose

  2. mgason
    Member
    Posted 4 years ago #

    Hi,
    I am afraid the minimum php requirement is 5.1 as it mentions on the plugin installation page.
    It would be nice if plugins provided that information in the short comments you see in wordpress plugins section.

  3. justinendler
    Member
    Posted 4 years ago #

    @mgason

    Good idea. As of version 1.6, that message will appear in the short description.

    Justin

  4. joseamo
    Member
    Posted 4 years ago #

    Thank you Mgason and Jutinendler for answering my post!!

    I was thinking if it was that the reason for showing this kind of error.

    It is a shame that php 4 is not yet supported...well I will have to wait to try it.

    Thank you for your comments!

    Best Regards from Spain
    Jose

  5. Shane Pearlman
    Modern Tribe
    Posted 4 years ago #

    Hi Jose,

    Php 4 came out over 10 years ago and is formally deprecated by the php community (http://en.wikipedia.org/wiki/PHP). Php 5 is even getting a bit long in the tooth and 6 should be coming out sooner or later. We will not providing support for older messages of PHP but we will certainly build a friendly error message (this is done) to let you know why it went Boom!

    =)

  6. joseamo
    Member
    Posted 4 years ago #

    Hi Shane,

    You are right about php4 but I share a multidomain hosting using it otherwise I would be using php5 as you recommend.

    A friendly error message would be good even in the description plugin page as well.

    Congratulations for your nice plugin which I hope to try when possible.

    Best Regards.
    Jose

  7. kelseydamas
    Member
    Posted 4 years ago #

    Hi Jose,

    Version 1.6, which is being released *right now* (!) will at least fail gracefully if you are using a downrevved version of PHP. I hope you are able to find a PHP 5 hosting provider soon!

  8. joseamo
    Member
    Posted 4 years ago #

    Hi Kelseydamas,

    Thank you for your comments on the new 1.6 release. Right, I'd better get a PHP5 provider quickly ;-)

    Best regards,
    Jose

Topic Closed

This topic has been closed to new replies.

About this Topic