WordPress.org

Ready to get started?Download WordPress

Forums

The Events Calendar
[resolved] Events show on Calendar but not Events List (23 posts)

  1. Steven Stern
    Member
    Posted 1 year ago #

    Following an upgrade from 1.65 to the current version of The Events Calendar:

    When I look at events/month, I see my upcoming events, and the upcoming events sidebar widget shows the upcoming events. BUT, when I click over to events/upcoming, there's nothing listed.

    http://wordpress.org/extend/plugins/the-events-calendar/

  2. Barry
    Member
    Posted 1 year ago #

    Hi Steven, difficult to say what the problem could be here.

    The fact that you updated from 1.6 is interesting: can I ask if you try creating a brand new event with a date sometime in the future does that even show up on events/upcoming?

    Failing that, can you try switching back temporarily to a default theme like Twenty Eleven (also try deactivating all of your other plugins) and see if that makes a difference here?

    Thanks - and I'm sorry to hear you've experienced this problem :-/

  3. Steven Stern
    Member
    Posted 1 year ago #

    I created a new event and it worked as expected. Because I have no old events set after today, I don't think this will be an issue going forward.

    BUT... and this is a bit BUT... when I went into calendar view and went back to August, I got this message on screen:

    You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'ORDER BY r_order' at line 1

  4. Barry
    Member
    Posted 1 year ago #

    Does that occur with all other plugins deactivated, and an active theme such as Twenty Eleven? I don't mean to harp on about that as a technique, but it helps to determine if the problem is in the current Events Calendar code or elsewhere - especially since I have trouble pegging that down to an Events Calendar query.

    Is that error verbatim as it was displayed to you?

  5. Steven Stern
    Member
    Posted 1 year ago #

    It turns out the be the plugin "related posts pages" version 2.0. The links in the source go to a dead domain, so I assume the plugin is dead, too. I'm going to leave it deactivated. Thanks.

  6. Barry
    Member
    Posted 1 year ago #

    Interesting to know - glad you figured this out :-)

  7. mattmilner
    Member
    Posted 1 year ago #

    Events showing in Calendar here but not Events List - I've tried other themes - same issue. I don't have an MySQL error showing up, it merely says 'no events' etc.

    Anyone?

  8. Steven Stern
    Member
    Posted 1 year ago #

    Matt: It's a pain, but assume an interfering plugin. Disable all plugins but TEC and see if it works. If so, turn them back on one at a time until it doesn't.

  9. mattmilner
    Member
    Posted 1 year ago #

    thx. I think it might be the theme - although there's documentation for the plugin on what page templates it uses, that section of the support could be better... trying to figure out exactly which template page has been somewhat annoying.

  10. mattmilner
    Member
    Posted 1 year ago #

    Can't deactivate plugins since I'm on a multi-site install... I've got the template using the page.php template.

    in lists.php if (have_posts()) : is throwing a null. I've checked for similar conditional statements in the theme's page.php - and removed them. Page.php is extremely simple - and everything displays except for

    <?php the_content(); ?>

    returns the null list.php contents.

  11. roblagatta
    Modern Tribe Support
    Plugin Author

    Posted 1 year ago #

    Hey mattmilner. Thanks for the note here; sorry to hear that you're having problems. I'm not sure if Barry saw the follow-up so I've sent it back to him and he should be able to take a look tomorrow. Any chance you've got a link to the site we can check out, in the interim? Would be helpful in diagnosing the issue.

    Thanks in advance!

  12. Barry
    Member
    Posted 1 year ago #

    Can't deactivate plugins since I'm on a multi-site install...

    Hey mattmilner - unfortunately that does rather limit what we can do to help. Are you able to provide a URL we can look at? It might be that there are some clues in the mark-up.

  13. mattmilner
    Member
    Posted 1 year ago #

    ack - didn't see the replies. Yes - http://digihum.mcgill.ca/events/past/

    the contents simply indicate 'no previous events' or 'no upcoming events'

    As far as I can tell it's a query issue, not the coding with the page per se.
    Nothing changes if I use the Event template or the Page Template page - both are empty.

    Here's a list of plugins we're using:

    Akismet
    Collabpress
    Degradable HTML5 Audio and Video
    Embed Javascript
    Exec-PHP
    Formidable
    Frontpage Manager
    iframe
    JW Player Plugin for WordPress
    Maintenance Mode
    Options Framework
    Shortcode Manager
    Supreme Google Webfonts
    The Events Calendar
    TinyMCE Advanced
    TubePress
    Twitter Tracker
    Wordpress MU Domain Mapping
    Zotpress

  14. mattmilner
    Member
    Posted 1 year ago #

    Ya, basically if I can get this solved, and get the events listing, we'll grab the Pro plugin, but I don't want to buy it until this is sorted...

  15. roblagatta
    Modern Tribe Support
    Plugin Author

    Posted 1 year ago #

    No problem, Matt! Going to have Barry take another look here in case he missed your last response. Stay tuned and thanks for your patience so far.

  16. Barry
    Member
    Posted 1 year ago #

    Hi Matt.

    Thanks for that link, unfortunately nothing is jumping out at me.

    If you can't deactivate the plugins can I ask you to try switching to a default, unmodified theme such as a stock copy of Twenty Eleven?

    If that doesn't yield any results then I'd say we're looking at a possible plugin conflict here. So one option is speaking to the network administrator and asking for his or her cooperation so you can disable other plugins - the other is that you create a staging or test environment and run up this test there, so that there is no impact on your production/live environment.

    Can you do that (please also ensure you are using the latest version of The Events Calendar) and let us know how you get on?

  17. mattmilner
    Member
    Posted 1 year ago #

    Hi barry - I'm the admin, but the multi-site is for an academic department, so it's tricky. I've notified the other admins that I'll be playing around, and asked when would be a good time to disable plugins on a rotating basis to try and isolate which one is causing the problem.

    It's not a theme issue - I've tried three other themes - one is TwentyEleven - and same thing.

    Could this be a residual problem with the posttype? I had tried a different plugin for events, but ripped it out. Could there be something still left in the tables for post types that might be causing a hiccup?

    I'll let you know what this turns up.

  18. Barry
    Member
    Posted 1 year ago #

    Sure. Just also note that disabling one plugin at a time, on a rotating basis, isn't necessarily as effective as disabling all non-Events plugins (as well as switching to a stock theme) simultaneously: if two plugins were conflicting - and that isn't massively uncommon - you might never isolate the problem.

    If custom posts are left over from another plugin I don't really envision this causing a problem since our own custom post types are appropriately namespaced - it's a possibility though.

    One other approach you can try is building a new WP multisite install and starting from scratch with a default theme and our plugins only. If everything works, build it up to replicate what you have on your live site.

  19. mattmilner
    Member
    Posted 1 year ago #

    Got it working. Not sure what it was. I systematically went through and deactivated, then reloaded the page. It looks like it was one of the following plugins

    Supreme Google Webfonts
    Shortcode Manager
    TinyMCE Advanced

    Not sure which one, since there were caching issues involved. Had to clear it out. I didn't have to make any changes, it's still working after reactivating all of the plugins. I haven't added a new event yet, but I'll keep an eye on it and let you know if new data fails to appear.

    Thanks for your patience.

  20. Barry
    Member
    Posted 1 year ago #

    Glad you're all sorted here :-)

  21. roblagatta
    Modern Tribe Support
    Plugin Author

    Posted 1 year ago #

    Thanks for confirming that you got this squared away, Matt. Bummer to hear this was a conflict of some kind but as other plugin conflict reports come through I'll keep an eye open for any of those 3 possibilities you'd suggested...maybe we'll be able to identify a pattern of some kind.

    I'm going to mark this RESOLVED for now, since it seems we're set, but please let us know if you need anything else.

  22. mattmilner
    Member
    Posted 1 year ago #

    Strange - ok - so looked again -Frontpage Manager handles categories for posts on the homepage. It was limiting the number of posts available for the events template in the same way it was limiting the posts for the homepage. I've disabled it for the network, and everything is fine. If there were no categories selected with this plugin, there were no upcoming events listed in the calendar.

    Hope this helps.

  23. roblagatta
    Modern Tribe Support
    Plugin Author

    Posted 1 year ago #

    Ah, that is definitely useful - I'm hoping we can add some code into 3.0 (which we're working on now) that should resolve this for users in the future. Fingers crossed.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.