WordPress.org

Ready to get started?Download WordPress

Forums

The Events Calendar
Event Details Missing in Admin View (16 posts)

  1. dbmayur
    Member
    Posted 2 years ago #

    When a Contributor creates an event, he/she adds all the details in the Title, Body, and second half of the page - the Events Calendar section and submits it for review (http://imageshack.us/photo/my-images/855/111201155705pm.png/)

    However, when I view the Event as an Administrator, all the details in the Events Calendar section are missing (http://imageshack.us/photo/my-images/687/111201155932pm.png/).

    This is the default installation and I haven't tweaked anything. Any kind of support would be highly appreciated.

    Regards,
    Mayur

    http://wordpress.org/extend/plugins/the-events-calendar/

  2. bwp
    Member
    Posted 2 years ago #

    Are you sure it's not just because the other user has it open for editing (as per the warning on the top)?

  3. dbmayur
    Member
    Posted 2 years ago #

    hey BWP, I am sure that's not the issue, though it may appear to be the issue. I've tried it multiple times from different PCs and from different users.

    Has anyone else faced the same issue? How did you resolve it?

    If not, would you know of a good alternative? I really like this though :)

  4. bwp
    Member
    Posted 2 years ago #

    The Event Calendar 1.65 (the one prior to this major 2.x upgrade) is still my favorite, but I'm watching "Events Manager" as well.

    Unfortunately it doesn't seem as if ANY actively-updated calendar plugin will treat events as regular posts, as TEC 1.6 did/does.

    That said, if you're using the new version, someone from Tribe will probably be able to help you...

  5. Jonas Grumby
    Member
    Posted 2 years ago #

    @dbmayur Which version of the plugin are you using? The screenshot looks like pre 2.0, in which case the issue may not exist in the latest version.

    I also have a site that I would like to let contributors post events on and am wondering of this is still an issue with later versions.

  6. bwp
    Member
    Posted 2 years ago #

    Nah, it's 2.x, Skipper -- there are separate Posts and Events links in the Dashboard sidebar.

    Oh, unless it's 1.x Pro; I never worked with that one.

  7. Jonas Grumby
    Member
    Posted 2 years ago #

    I have 2.0.1 working nicely. I'll have to create a Contributor ID and try it.

  8. dbmayur
    Member
    Posted 2 years ago #

    i am currently using v2.0. can i get the 1.6 version from somewhere else?

  9. dbmayur
    Member
    Posted 2 years ago #

    @jonas...thanks. please let us know how it went for you.

  10. Jonas Grumby
    Member
    Posted 2 years ago #

    With 2.0.1 unfortunately when I log in as a Contributor and create an event, as soon as I hit Submit For Review all of the event details in The Events Calendar dialog box disappear. Only the event title and whatever was entered into the main post box remain.

    If I create an Event with an Author role, this doesn't happen. It would be nice to get the contributor role to work since Authors have permission to publish and I would prefer to review post details before they are published.

    One more thing to add to the punch list apparently.

  11. bwp
    Member
    Posted 2 years ago #

    (grumble grumble and one more thing that worked out of the box when events were posts grumble grumble :) )

    dbmayur, to answer your earlier question, 1.6 downloads are available off the plugin's regular WordPress.org page at http://wordpress.org/extend/plugins/the-events-calendar/download/

    But you might want to stick with 2.x as 1.6 is now unsupported.

  12. biscuitstudios
    Member
    Posted 2 years ago #

    dbmayur, same thing happening on a new site of ours... clean install of WP 3.2.1 and The Events Calendar 2.0.1.

    when saving an event (as an admin) all the data within the events module is lost... other information outside of that (like noted in your uploaded image) is retained.

    EDIT: no other plugins activated

    don't have an answer, but it thought i'd also mention we have a 2.0 working just fine on a site (same server setup) that was an upgrade from 1.6.5 using TEC's built in migration tool.

  13. Jonas Grumby
    Member
    Posted 2 years ago #

    Mine only fails when I try to create an event as a Contributor.

  14. biscuitstudios
    Member
    Posted 2 years ago #

    Jonas... i just reverted my clean 2.0.1 install back to 2.0 and everything is now saving just fine... so some revision in the 2.0.1 update is causing the problem?

  15. Jonas Grumby
    Member
    Posted 2 years ago #

    It seems like a few people have reported a problem with creating events with the Contributor role. I am having that problem with 2.0.1 and have not tested it with 2.0.

  16. dbmayur
    Member
    Posted 2 years ago #

    thanks for all the feedback, guys. due to lack of time, i moved to events manager. if this is fixed in a future release, i might come back. i just like the simplicity of TEC.

    thanks again!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic