WordPress.org

Ready to get started?Download WordPress

Forums

The Events Calendar
[resolved] Data not saving in fields (60 posts)

  1. trewknowledge
    Member
    Posted 2 years ago #

    Looking forward to the fix for this issue!

  2. mgreis
    Member
    Posted 2 years ago #

    Add me to 2cats and all the others experiencing this problem. I can create an entry with a venue and it saves and displays properly. But the edit screen for the entry then clears all the venue information, so if a user edits the event and saves it, all the venue information disappears from the post (unless of course the user has re-entered it).

    I haven't noticed any of the other problems in editing an event - anything that I specify seems to be reflected correctly when the item is updated.

    Looking forward to a fix soon! This is an extremely valuable plug-in.

  3. kchez
    Member
    Posted 2 years ago #

    Keep up the good work. Looking forward to the fix soon!

  4. Josh Frank
    Member
    Posted 2 years ago #

    I echo 2cats and mgrels - I can create the event, add the venue & organizer info, publish, and it goes live to the site. But then if I need to go back to the Post Editor to edit the event, all of those fields are blank.

    Would uninstalling and then re-installing a previous version of the plug-in work? I still have a zipped copy of 1.6.4.

  5. joemcgill
    Member
    Posted 2 years ago #

    @Josh - I wouldn't recommend downgrading past version 2.0 because the way events are handled in the database changed so much. Version 2.0.2 is still working (though you can't update the venue info after you first input it). You can download that version here:
    http://downloads.wordpress.org/plugin/the-events-calendar.2.0.2.zip

    - Joe

  6. Josh Frank
    Member
    Posted 2 years ago #

    @Joe - Thanks, I just found out myself! Had to reset my permalinks among other things.

    I decided to try reverting to 2.0 and that seems to have done the trick - no more disappearing Venue and Organizing info. If that is the feature that is really throwing people for a loop, and there aren't other bugs related to 2.0, I suggest backing up, then deleting the current version and installing 2.0. Looking at the change log, I don't see too many bugs and feature updates that will make using 2.0 until 2.0.3 or 2.1 is released a problem.

    Of course, your mileage may vary!

    http://downloads.wordpress.org/plugin/the-events-calendar.2.0.zip

  7. mojowill
    Member
    Posted 2 years ago #

    Any proper updates coming this seems to be getting progressively worse with each release?

  8. Josh Frank
    Member
    Posted 2 years ago #

    I realized that my current project would really benefit from recurring events, so I popped for the individual license. The pro version doesn't seem to have the same issue. =/

  9. roblagatta
    Modern Tribe Support
    Plugin Author

    Posted 2 years ago #

    Hey Mojowill. We're working on our 2.1 release now; we feel your pain on this and apologize if the plugin gets worse with each release. While we're trying to patch everything we can from release to release, some things inevitably get broken and others not fixed for everyone - things we don't realize until it's out there being used by folks on a bunch of different setups. If you're interested in testing out new code as it becomes available - but not necessarily officially released - you can always feel free to email me (rob at tri.be) and I can get you what we've currently got at that moment in time. This way if we do fix it along the way you aren't waiting for an official release to get something that we've already fixed. We do want to make this right by you guys, though, and apologize for persistent problems like this.

    Josh: awesome to hear the PRO route fixed your issue. We're working hard to get this resolved for core/free users, too, so they don't feel like upgrading to PRO is necessary for a working plugin.

  10. trewknowledge
    Member
    Posted 2 years ago #

    Thanks Rob, the code you sent me solved my problem!

  11. dpDesignz
    Member
    Posted 2 years ago #

    Any update on how far away this will be?

  12. roblagatta
    Modern Tribe Support
    Plugin Author

    Posted 2 years ago #

    Just a heads up to all that the majority of feedback I've gotten from users emailing me about this seems to indicate the new code resolves it. The offer still stands for anyone interested in reaching out there.

    To answer dpDesignz: the fix should be deployed with the rest of the 2.1 code sometime between now and the end of March. Hopefully sooner rather than later...though it all depends on how quickly we can get the remaining bugs out.

  13. dpDesignz
    Member
    Posted 2 years ago #

    2.1 is working exactly how it's suppose to. Thanks. Some cool new features

  14. stewarty
    Member
    Posted 2 years ago #

    After a few emails with Rob it looks like the 2.1 release is going to fix this issue.

  15. jwilson77
    Member
    Posted 2 years ago #

    Rob - I tried to email you for the fix, but the email was returned undelivered. Is there any other way I can grab the fix code from you? Or perhaps a different email? Thanks!

  16. dpDesignz
    Member
    Posted 2 years ago #

    Did you try rob[at]tri[dot]be? I just had an email from him.

  17. roblagatta
    Modern Tribe Support
    Plugin Author

    Posted 2 years ago #

    Hey jwilson77. The method dpDesignz describes is how you have to format the email; ie at http://tri.be/. Hope that helps, let me know if it still bounces back. Glad to hear the issue is by and large resolved for the other folks so far!

  18. msharps
    Member
    Posted 2 years ago #

    Rob, thanks for emailing the latest code - it works great!

  19. fecar
    Member
    Posted 2 years ago #

    Rob, thank you for emailing me quickly with the latest code, it works great and fixed this issue!

  20. mojowill
    Member
    Posted 2 years ago #

    I have tried emailing twice now from 2 addresses and not received the fix?

    Just wondering if there is a fix and it works why hasn't it just been applied to the plugin and pushed to the repo so we can all benefit from the update?

  21. dpDesignz
    Member
    Posted 2 years ago #

    Hey @Mojowill

    1) Have you tried checking your spam filter

    2) As Rob has said it is still very much in Beta mode. There are still a few bugs in there. :)

  22. cstokley
    Member
    Posted 2 years ago #

    Rob, thank you for sending me the beta code. I am now seeing no problems with editing events; location and organizer data are retained.

  23. mojowill
    Member
    Posted 2 years ago #

    Got the updated code from Rob yesterday and seems to be working well! Cheers, hopefully see a proper release soon!

  24. roblagatta
    Modern Tribe Support
    Plugin Author

    Posted 2 years ago #

    As a heads up: we hit a couple bugs related to the 1.6.5->2.0.4 migration that delayed this a bit, but 2.0.4 should be out by the end of the week. Anyone who needs the code in the interim, do feel free to reach out. Seems to be working for most users so far.

  25. exploitationvm
    Member
    Posted 2 years ago #

    Got the updated interim code from Rob and it works for me. Thanks

  26. roblagatta
    Modern Tribe Support
    Plugin Author

    Posted 2 years ago #

    Awesome to hear! Since this seems to be fixed for pretty much everyone with the 2.0.4 update, I'm going to mark this thread "Resolved." Please let us know if any other issues arise and thanks for being patient as we worked through this.

  27. SPLondon
    Member
    Posted 1 year ago #

    We updgraded to 3.3.1 and the Events were automatically added to our menu options and changed our whole website formatting and functionality. This took quite a lot of time to fix.
    We're still using 3.3.1 and this bugs is still current for us.
    We cannot amend or delete the Event Location Details or other details, after they have been set at the initial Publish stage.
    This is a real issue for us as many customers get lost on their way to an event.
    Can anyone assist?

  28. jonahcoyote
    Member
    Posted 1 year ago #

    Hey SPLondon, sorry to hear you are having issues. Have you tried deactivating other plugins and/or switching your theme to see if this helps? There may be some conflicts going on and that would be a good place to start to rule them out. Also, are you running the latest version of the plugin 2.0.6?

  29. bajun
    Member
    Posted 1 year ago #

    hello guys
    so,I'm running latest version of plugin - 2.0.8
    And WP is 3.4.1
    but I still have problem with saving EVENT LOCATION DETAILS
    I heard that exists some fix of this problem,but I can't find it.

  30. jonahcoyote
    Member
    Posted 1 year ago #

    Hi bajun,

    First try deactivating all other plugins to see if it's a plugin conflict and if that doesn't help try switching to the Twenty Eleven theme to see if its a theme conflict.

    I hope that helps!

    - Jonah

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic