WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: The Events Calendar] Changing language (14 posts)

  1. Markus Pettersson
    Member
    Posted 4 years ago #

    I have The Events Calendar and want it in Swedish, how do I change that? The WordPress installation is already in Swedish, but EventsCal is still in English.

  2. Shane Pearlman
    Modern Tribe
    Posted 4 years ago #

    In theory it should work. I'd recommend you post in the swedish translation thread and Kaj or someone else can help.

  3. Vayu Robins
    Member
    Posted 4 years ago #

    Hi.

    Did anyone find an answer to this issue? I have the same problem, everything is set to Danish, but the Event calendar is in English.

    Cordially
    Vayu

  4. justinendler
    Member
    Posted 4 years ago #

    Hi,

    Just making sure, the variable WP_LANG in wp-config.php is set: define ('WPLANG', 'sv_SE'); in vampyrse's case and define ('WPLANG', 'da_DA'); in Vayu's case, correct?

    Justin

  5. fxbenard
    Member
    Posted 4 years ago #

    I have the same issue with my french installation. any idea?
    my config is set to WPLANG', 'fr_FR

  6. fxbenard
    Member
    Posted 4 years ago #

    the time is working like setup in my wp admin center but the date stays in english.

  7. fxbenard
    Member
    Posted 4 years ago #

    I found "the-events-calendar-fr_FR.po" and made the changes with poetit to make it work in french but the changes doesn't show in the interface?

  8. fxbenard
    Member
    Posted 4 years ago #

    Me again, i'll found the way, erased all the lang.po and .mo and put back only the french ones.
    Everything works fine except the next and previous month who stays in english

  9. CarstenMatzon
    Member
    Posted 4 years ago #

    Same problem here.
    I edites wp-config.php to "define ('WPLANG', 'da_DK');".
    My /plugins/the-events-calendar/lang/ includes a "the-events-calendar-da_DA.po" and a "the-events-calendar-da_DA.mo" file. But still everything is in English!?

  10. eddi
    Member
    Posted 4 years ago #

    I am having the same problem with Spanish, I have changed my wp-config.php to ('WPLANG', 'se_SE'); everything changed to Spanish except the months
    http://laonenesscarteria.es

  11. eddi
    Member
    Posted 4 years ago #

    Answering my own question, who ever created the .PO file didn't include the months, why would you swim a half across the lake and then turn back..

  12. darinez
    Member
    Posted 4 years ago #

    Hi guys,

    I experienced the same problem and luckily I found a solution, at least to my problem.

    I guess most of the stuff that you find still in english is the dates: names of months and days. Initially I thought that the "non-translating" problem had something to do with using the date() function instead of a different one that could be localized. However the solution has been "simpler". The process:

    1) Edit the "the-events-calendar.class.php" file located in the root directory of the plugin.

    2) Search for the "public function monthNames( $short = false )" and translate the values that the $months array take, for example:

    $months = array( 'Jan' => __('Ene', $this->pluginDomain),

    $months = array( 'January' => __('Enero', $this->pluginDomain),

    Change only the value 'Ene', 'Enero' not the key of the array that should continue being: 'Jan', 'January'...

    Save the file an upload to the corresponding root directory of the plugin on your WordPress installation.

    Regarding some other Words that have not been translated in the .po and .mo files, I recommend reading this post of WordPress documentation. http://codex.wordpress.org/Translating_WordPress

    In order for the changes to take effect you not only need to modify the readable .po file but you also need to regenerate the .mo file which is the one that guarantees the translation will take effect. I have used the program PoEdit for windows, free of charge, that you can use to edit the readable .po files and automatically generates the corresponding .mo files upon save. You can download the program from this link:
    http://sourceforge.net/projects/poedit/files/poedit/1.4.6/poedit-1.4.6-setup.exe/download

    The first time you use the program it will prompt for an error asking to change the default "language team" value, just go to 'Catalog' submenu 'Option' and replace the default name of the 'Team' with something meaningful. I hope it helps...

    Cheers!

  13. eddi
    Member
    Posted 4 years ago #

    Thank you for your post darinez, after many hours of trying to get this to work, you gave me the solution to my problem with poedit.

  14. mlynge
    Member
    Posted 3 years ago #

    Thank you darinez this also solved my problem with months. It could be great with a fix that would make it possible to translate the months instead.

    Regarding WP_LANG. When defined as danish it should be define ('WPLANG', 'da_DK'); not ('WPLANG', 'da_DA');
    This however does not work with the provided da_DA.mo and da_DA.po files included with the-events-calendar.
    You can fix this by just opening the po file in Poedit. Follow the steps provided by darinez and then save the file as da_DK.po

    Martin

Topic Closed

This topic has been closed to new replies.

About this Topic