WordPress.org

Ready to get started?Download WordPress

Forums

The Events Calendar
[resolved] Calender buttons misplaced (69 posts)

  1. bsmpower
    Member
    Posted 2 years ago #

    Hi!

    I have a problem after creating an event. The layout of the page is suddenly changed. The buttons show up in the top of my website (on the logo). It worked correctly for a few days?

    Link to the calendar page with the misplaced buttons:
    http://test.fleeve.nl/events/maand/

    Can someone help me with this problem? Thanks in advance!

    Kind regards,

    Stijn

    http://wordpress.org/extend/plugins/the-events-calendar/

  2. roblagatta
    Modern Tribe Support
    Plugin Author

    Posted 2 years ago #

    Thanks for the note, bsmpower. I see the issue you're noting. Is it possible you installed another plugin that could be conflicting and causing this? A few things I'd suggest:

    * Delete that event you created and see if it reverts back to looking normal;
    * Try the different templating options available under Settings -> The Events Calendar to see if those help solve it; and
    * Make sure that you're running Events Calendar 2.0.3 and not an earlier release.

    If you could confirm with me about those, I can keep investigating and can get a dev to chime in as needed.

  3. bsmpower
    Member
    Posted 2 years ago #

    Hi,

    Still doesn't work. Deleted the plugin en installed it again. Same problem. Strange thing is that the problem occured after adding a event. Since then the calendar isn't shown correctly. So I don't think it has anything to do with another plugin.

    Anything else I can try?? Thanks for your support!

  4. roblagatta
    Modern Tribe Support
    Plugin Author

    Posted 2 years ago #

    Hey bsmpower. Dang; bummer to hear that didn't do the trick. Do you want to shoot me an email to try the updated code? It's not quite ready for 2.1 release, but it's changed a bit since 2.0.3 and would be good to know if it resolves your issue. It's still technically a beta but as long as you backup before installing you should be fine.

    Shoot me an email (rob at tri.be) if you're interested and I'll hook you up. Apologies for the inconvenience so far.

  5. bsmpower
    Member
    Posted 2 years ago #

    The problem is back. I also know when I'm getting the error. When their is no event in a specific month the buttons move up to my banner. When you go to a month with a event, then their is no problem. Please have another look at:

    FAULT: http://test.fleeve.nl/agenda/2012-03
    GOOD: http://test.fleeve.nl/agenda/2012-04

    Hope you can help me out! Thanks in advance!

    Kind regards,

    Stijn

  6. roblagatta
    Modern Tribe Support
    Plugin Author

    Posted 2 years ago #

    Hey bsmpower. Have you updated to the official 2.0.4 release, or are you running with the beta? We've had a few users report this but for the vast majority of them it's a conflict with another theme or the plugin. Let me know about both those points and we can keep troubleshooting as needed.

  7. bsmpower
    Member
    Posted 2 years ago #

    Hi, I used the beta you send me by mail. I deleted that version and tried the official 2.0.4. But now I have problems with my FTP. Half of the file transfers fail... No problem with other files on my FTP. It is also not possible to upload the .zip. I get the error:
    PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature

    Hope you can help me!

  8. geoffgraham
    Member
    Posted 2 years ago #

    Hey roblagatta, I'm having a similar (the same?) issue.

    While in gridview, the calendar header looks great as long as an event is published in the current month.

    For example, screenshot of current month with one event:
    http://cl.ly/Efpl

    However, when no event is posted for the given month, the header layout goes a little haywire.

    Example, screenshot of next month with no events:
    http://cl.ly/Eh07

    I am running the official 2.0.4 install and have deactivated all plugins in case any conflicts were causing the issue. Everything else seems to work great.

    Do you have any thoughts or ideas about what is happening?

    Thanks for your help!

  9. bsmpower
    Member
    Posted 2 years ago #

    Any update about the problems we have ?

  10. roblagatta
    Modern Tribe Support
    Plugin Author

    Posted 2 years ago #

    Hi all. Thanks for the follow-up. Bsmpower: it sounds like the FTP-related problem you're having is almost certainly a product of some outside force and not The Events Calendar itself. You don't want to upload the ZIP itself, either...the file should be unzipped and just the folder added. That possibly your issue?

    Geoffgraham: I'm seeing the issue there, yes. I should be able to get a dev on our end to take a look and try to identify what's up here. Can you confirm as to the theme you're using?

  11. jonahcoyote
    Member
    Posted 2 years ago #

    Hey geoffgraham, what theme are you using and can I take a look at your actual website?

  12. geoffgraham
    Member
    Posted 2 years ago #

    Hey roblagatta, thanks for the follow up!

    I'm developing a custom theme based on TwentyEleven. I've used the plugin on several other sites using similar code, but this is the first one since 1.8.

  13. geoffgraham
    Member
    Posted 2 years ago #

    @jonahcoyote: I'm developing locally, but I could put what I've got on GitHub if you need to take a look.

    Thanks!

  14. jonahcoyote
    Member
    Posted 2 years ago #

    I do need to take a look to troubleshoot further.

  15. geoffgraham
    Member
    Posted 2 years ago #

  16. jonahcoyote
    Member
    Posted 2 years ago #

    As I suspected, this is due to a bug that we have filed and will be fixing ASAP. Keep an eye out for an update!

  17. geoffgraham
    Member
    Posted 2 years ago #

    Thanks! I'll keep my eyes open for the update.

  18. jonahcoyote
    Member
    Posted 2 years ago #

    Hey Geoff, just a quick update. This is fixed in 2.0.5 which we are planning on releasing soon. I can't give you an exact date, but it will be soon :)

  19. bsmpower
    Member
    Posted 2 years ago #

    Hi Jonah,do you have an update? I want to go live with the website, but need this calender :). Hope you have a fix soon. Thanks in advance!!

  20. jonahcoyote
    Member
    Posted 2 years ago #

    Hey bsmpower, the only update I have is that the release should be soon but there's no definite date I can supply :)

  21. geoffgraham
    Member
    Posted 2 years ago #

    Hey bsmpower, I got the 2.0.5 update but it looks like the alignment issue is still there. Did this update try to address the issue, or is that something you guys are working on?

    Thanks!

  22. jonahcoyote
    Member
    Posted 2 years ago #

    Hey geoffgraham, are you running 2.0.5 on the remote test site you posted previously? One thing to do would be to make sure you are migrating any new code into any overridden template files (files placed in an 'events' folder in your theme) because there may be changes that haven't made it into them.

  23. geoffgraham
    Member
    Posted 2 years ago #

    Hey jonahcoyote, thanks for responding.

    Yeah, I'm running 2.0.5 on the remote test and am using the default plugin templates. Nothing is overridden as far as I know.

    Any thoughts? I'm pretty stuck.

  24. jonahcoyote
    Member
    Posted 2 years ago #

    Shoot, it sounds like this may still be a bug then. I'll re-open the ticket but this likely won't get fixed until 2.1 and sorry but I don't have any ETA on that...

  25. geoffgraham
    Member
    Posted 2 years ago #

    No worries, I'll keep my eyes open for the update. Thanks for checking it out.

  26. bsmpower
    Member
    Posted 2 years ago #

    "Hey bsmpower, the only update I have is that the release should be soon but there's no definite date I can supply :)"

    It is about 3 weeks later now. Any update :-s yet??

  27. jonahcoyote
    Member
    Posted 2 years ago #

    Yep, 2.0.5 came out on 3/26 - did you update yet? It looks like it may still be a problem so we've reopened the ticket to revisit again. But, try updating and see if it fixes it for you.

  28. geoffgraham
    Member
    Posted 1 year ago #

    I saw that 2.0.6 was released and I've upgraded, but still have the same issue.

    I'm using another calendar plugin in the meantime, but would really like to be using The Events Calendar--it's by far the best plugin for what I'm trying to do.

    Here's an updated link to the formatting issue in the header form:
    http://foursquare.bethouawesome.com/events-calendar/

  29. roblagatta
    Modern Tribe Support
    Plugin Author

    Posted 1 year ago #

    Hi Geoff. Thanks for the follow-up; bummer to hear that this is still a problem. Can you re-activate that link? When I click it I'm taken to a dead page. Want to help you get this resolved though...

  30. geoffgraham
    Member
    Posted 1 year ago #

    Thanks do the follow-up!

    Here's a new link:
    http://foursquare.bethouawesome.com/calendar

    You can see the issue when navigating to August or any other month with no scheduled events.

    Thanks again for checking this out for me. Let me know if there's something I can do to help you guys diagnose!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic