WordPress.org

Ready to get started?Download WordPress

Forums

Testimonials by Aihrus
[resolved] [Plugin: Testimonials Widget] Not rotating through posts at all (8 posts)

  1. ADubb5
    Member
    Posted 2 years ago #

    Hi. I am utilizing your plugin on two different sites. Everything was functioning great, but now the testimonials do not rotate at all. I have the refresh rate at 5, not zero. Any ideas?

    Thanks in advance for your help.

    http://wordpress.org/extend/plugins/testimonials-widget/

  2. ADubb5
    Member
    Posted 2 years ago #

    Any ideas? I like this plugin - but I really need it to function correctly. Please see the dev version of the website I'm working on dev.themeyvngroup.com/coloursofbeauty

  3. Michael Cannon
    Member
    Plugin Author

    Posted 2 years ago #

    If you open your site and check the Console debug screen, you'll find that jQuery isn't loading before the testimonials call. As such, no rotation.

  4. Michael Cannon
    Member
    Plugin Author

    Posted 2 years ago #

  5. uniquewaves
    Member
    Posted 2 years ago #

    Hi There,
    I am having a similar problem... I have been using this great widget on:
    http://warbornefarm.co.uk/warborne/?page_id=2
    and it rotates through the testimonials great.

    But on the following they don't rotate:
    http://offers.healthy-options.co.uk/

    Any suggestions would be greatly received...
    Many Thanks!!!

  6. Michael Cannon
    Member
    Plugin Author

    Posted 2 years ago #

    There's an…

    Uncaught TypeError: Object #<Object> has no method 'first' in nextTestimonial2 on line 230 of http://offers.healthy-options.co.uk/ (anonymous function)

    Off the top of my head, I'm not sure how to fix this one. Normally, you check that jQuery is loaded before the plugin and it seems to be.

    Your jQuery is version 1.7.1. That's what I've got running at TYPO3Vagabond.com and elsewhere.

    The testimonials code otherwise looks fine regards to css, html and javascript. Therefore, I'm stumped at this point and don't have time till later to try and resolve.

  7. jonathan.rivera84
    Member
    Posted 2 years ago #

    In the testimonials-widget.php (located in the plugins->testimonials-widget directory ) Find the following line of code

    <script type="text/javascript">
    			function nextTestimonial$widget_number() {
    				if (!jQuery('.$id_base').first().hasClass('hovered'))

    you want to change the .first() method to .eq(0)

    <script type="text/javascript">
    			function nextTestimonial$widget_number() {
    				if (!jQuery('.$id_base').eq(0).hasClass('hovered'))

    It works on some themes, and some it does not as I have one clients website that works with .first() and others that need the .eq(0) . Also make sure you have loaded JQuery in your header correctly.

  8. Michael Cannon
    Member
    Plugin Author

    Posted 2 years ago #

    Thank you for the eq() vs first() idea. How do the two differ?

    The real problem around first() comes from there being two different version of loaded. I think that's a bigger problem than testimonials not working.

    Thoughts?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic