WordPress.org

Ready to get started?Download WordPress

Forums

Testimonials by Aihrus
[resolved] [Plugin: Testimonials Widget] Fixed height of testimonials widget (13 posts)

  1. padredenny
    Member
    Posted 2 years ago #

    Is there a way to make the height of the testimonials widget automatically adjust depending on the length of text? Widgets below this one can be overridden if the text is too long, and if it's too short, there's a lot of white space at the bottom.

    I understand why this might be affected by the idea that testimonials fade in and out. But I'm currently setting the widget not to rotate at all.

    Any help would be appreciated. Thanks.

    http://wordpress.org/extend/plugins/testimonials-widget/

  2. Pothi
    Member
    Posted 2 years ago #

    I had the same issue. In testimonials-widget.css, you can change the 'position' value to relative from absolute. It works for me. I didn't test it in IE, though.

    .testimonialswidget_testimonial {
    	position: absolute;
    	top: 0;
    	left: 0;
    	display: none;
    }

    Hope this helps!

  3. Michael Cannon
    Member
    Plugin Author

    Posted 2 years ago #

    Pothi,

    Thank you for helping out here. Obviously, I missed this question.

    Padredanny, did the response above help?

    Michael

  4. kaotik
    Member
    Posted 2 years ago #

    No matter what I do, I cannot adjust the height for the testimonials on this plugin. The above answer doesn't solve the issue. Please address how to correct the height. There's too much white space after each entry.

    Thanks.

  5. Michael Cannon
    Member
    Plugin Author

    Posted 2 years ago #

    kaotik,

    Can you please provide a link to your site with the troublesome testimonials parts?

    Next, what's your placement desires so that I can make recommendations.

    Michael

  6. Michael Cannon
    Member
    Plugin Author

    Posted 1 year ago #

    Do you still need help? If so, with what specifically and where?

  7. Michael Cannon
    Member
    Plugin Author

    Posted 1 year ago #

    Can you please try the 2.0.1 release and let me know how it goes?

    Regarding removal of the min-height, I can use some ideas from people on making it happen safely for widgets, posts and pages.

  8. penncoremedia
    Member
    Posted 1 year ago #

    Hi I am having the same problem, [testimonialswidget_widget], on my main page it is inserted in the post. Problem is so much white space after the shortcode. I just installed today so I have the latest version.

  9. Michael Cannon
    Member
    Plugin Author

    Posted 1 year ago #

    If you're using the shortcode, have you tried the min_height option?

    [testimonialswidget_widget min_height=100]

  10. Michael Cannon
    Member
    Plugin Author

    Posted 1 year ago #

    Have you tried the min_height option mentioned above? Did it fix your issue?

  11. penncoremedia
    Member
    Posted 1 year ago #

    Yes, sorry forgot to try this out, just did now, works perfect!

  12. ladymsdiva
    Member
    Posted 1 year ago #

    Trying to figure out how Pothi's solution could work but the "display:none" declaration has stumped me. Yeah, I guess not displaying it solves the min-height problem if there's nothing to display. Either there's something missing there or I just made a bad joke...

  13. Michael Cannon
    Member
    Plugin Author

    Posted 1 year ago #

    @ladymsdiva, the display: none; is there because during rotation, the CSS class .testimonialwidget_active is applied which contains display: block;.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic