WordPress.org

Ready to get started?Download WordPress

Forums

Testimonials Pro
Got random "\" appearing in my testimonials (7 posts)

  1. orakaa
    Member
    Posted 1 year ago #

    Hi and thank you for your work on this plugin.
    I have a problem: I have correctly installed the plugin on my website but the text I try to copy in a new Testimonial appear with "\" randomly in the text (before and after " or ' for instance).
    I can't use the plugin like that. Do you have any idea what might be the problem?

    FYI I have installed the plugin on the sidebar of my website. It can be seen here for instance http://www.boirekangen.org/?home_page=solution

    http://wordpress.org/extend/plugins/testimonials-pro/

  2. orakaa
    Member
    Posted 1 year ago #

    Just for information, my character set is UTF-8 for my website.
    I have checked in Testimonials Pro source files (in the plugin editor on WordPress' admin board) and it also seems to be set to UTF-8 (unless there is another place where I would have to look)

  3. Dimitar A.
    Member
    Plugin Author

    Posted 1 year ago #

    Oraka please check I updated the plugin to replace the \ sign before ' or " when you view the website. You can use str_replace for anywhere in the plugin, to fix this problem.

  4. orakaa
    Member
    Posted 1 year ago #

    Thank you for your answer.

    I have checked, uninstalled and reinstalled the latest version available here but as you can see on my link (http://www.boirekangen.org/?home_page=solution ) on the right side of the page, you can see a testimonial appearing (text is in french, but doesn't matter).

    There are backslashes before single and double quote marks (' and "). I have tried to look on the web and found a possible solution here http://fearlessflyer.com/2009/08/getting-rid-of-unwanted-backslashes-in-wordpress-form-input/ but this solution doesn't work (copied the code in the function.php but still got the same result).

    Regarding the "str_replace" function, I don't understand what you mean.
    If this topic has already been addressed somewhere else, can you forward me a link?

    Thank you in advance, Fred

  5. Danielle Hickinbotham
    Member
    Posted 1 year ago #

    I am also having this issue. I just installed this plugin tonight, but have been unable to get the \ before a ' to go away. It's like it's trying to escape the '. Any luck fixing this issue?

  6. 4tuneinteractive
    Member
    Posted 1 year ago #

    I managed to get this fixed.

    You will have to go to 'edit plugins' in the plugins section of WordPress , open the testimonials-pro plugin page.

    in the section where you see the following code :
    $TP_name = trim($TP_data->TP_name);
    $TP_desc = trim($TP_data->TP_desc);

    enter the following immediately after:

    $TP_desc = stripslashes($TP_desc);

    this will strip the slashes from the actual testimonial string.

  7. Danielle Hickinbotham
    Member
    Posted 1 year ago #

    Thank you 4tuneinteractive, that worked just as expected! (Why I didn't think of that I don't know hahaha)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic