WordPress.org

Ready to get started?Download WordPress

Forums

Taxonomy Images
hide_empty not parsed (5 posts)

  1. Raul Illana
    Member
    Posted 2 years ago #

    Hi, first of all let me say thanks for such an useful plugin. :)

    BTW, in the following code hide_empty is not parsed, or I'm doing something wrong.

    $terms = apply_filters('taxonomy-images-get-terms', '', array(
    	'taxonomy'   => 'ciudades',
    	'hide_empty' => 0
    ));

    I can see only the taxonomies with contents. :(

    ┬┐Any tips?

    Best,

    http://wordpress.org/extend/plugins/taxonomy-images/

  2. Syed Balkhi
    Member
    Posted 2 years ago #

    hide_empty is not a parameter for that filter. You have to use hide_empty in term_args.

    Example:

    $terms = apply_filters( 'taxonomy-images-get-terms', '', array('taxonomy'=>'work-clients', 'image_size' => 'Fullsize', 'term_args' => 'hide_empty=0') );

  3. Raul Illana
    Member
    Posted 2 years ago #

    Hi Syed, got it from a while, but thanks for taking time to respond.

    $terms = apply_filters('taxonomy-images-get-terms', '', array(
    	'taxonomy'  => 'ciudades',
    	'term_args' => array(
    		'hide_empty' => 0,
    		'parent' => 0
    	)
    ));

    This is in what I've ended. For if it helps some one. :)

    Regards.

  4. Gaurav Raghav
    Member
    Posted 2 years ago #

    Thanks for the help Syed

  5. Kulwant Singh
    Member
    Posted 1 year ago #

    Great help !!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic