WordPress.org

Ready to get started?Download WordPress

Forums

Table of Contents Plus
Shortcodes not working (4 posts)

  1. yositsitsu
    Member
    Posted 2 years ago #

    Hi, this is a very useful piece of a plugin!

    Unfortunately, the shortcodes [toc], [no_toc] do not work for me.

    Also, occasionally there is an error message at the top of the TOC+ settings page, saying "Save Failed". (A minor thing, but still a bug)

    Thanks!
    Yosi Tsitsu

    http://wordpress.org/extend/plugins/table-of-contents-plus/

  2. Mike
    Member
    Plugin Author

    Posted 2 years ago #

    Have you had a look at the "Where's my table of contents" section under the help tab? If so, do your pages and/or posts have real headings? What I mean by "real headings" is that you have to use headings 1 through to 6 via the drop down box in the visual editor. If you do not see a drop down, you need to expand it by clicking the kitchen sink button. Also, by default, you need at least four of these real headings before the TOC will appear.

    Sorry for the lateness - I guess the RSS feed for TOC+ forum articles no longer works :(

  3. yositsitsu
    Member
    Posted 2 years ago #

    Thanks for t he reply Michael - actually I am pretty technical and make sure to check I am OK with the help before I post.

    i know there is the minimum setting and that it works only with headings. The thing is that as long as it is was set to work automatically for all post and pages, it worked just fine.

    After I realized I had TOCs placed on landing pages lol, i changed it to manual and tired the shortocde - nothing happened.

    As I said, automatic mode works OK though.

  4. Mike
    Member
    Plugin Author

    Posted 2 years ago #

    That's a strange one. I'm wondering if the shortcodes are being triggered at all (or maybe too soon). Could you try delaying it by by editing toc.php and on line 129 change from
    add_filter( 'the_content', array(&$this, 'the_content'), 11 );

    to
    add_filter( 'the_content', array(&$this, 'the_content'), 100 );

    I currently have this in trunk and have it ready to be rolled out in the next release. This simple change makes it more friendly with SEO related plugins that try to munge anchor links on the current page. Hopefully it works for you too.

    On discussion of the TOC appearing on landing pages when set to automatically trigger, I have tried to limit it to appear appropriately on the correct page but may have missed some. The exclusions I currently have are:

    !is_search() && !is_archive() && !is_front_page()

    How is your landing page created? Was it hand crafted? If so, try using the_excerpt rather than the_content?

    Did you experiment with the TOC+ widget by any chance? If so, make sure you disable the "Show the table of contents only in the sidebar" in the widget, then save, then remove the widget.

    Finally re failed saving. I would firstly suggest to verify that the message actually originates from TOC+ as I've come across many themes and plugins with a global admin presence to this same effect (eg they have a global form/notification area in the admin section which can sometimes get in the way). Secondly, once verified that it comes from TOC+, it results in this only if your nonce security tokens do not match (eg your sessions differ; you didn't actually request a change; you submitted from an unknown link). When you visit the settings page, it does NOT initiate a save operation until you click the update options button. Check out nonces for more information.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic