WordPress.org

Ready to get started?Download WordPress

Forums

SyntaxHighlighter Evolved
Problems with IE and Chrome Browsers (8 posts)

  1. iceflatline
    Member
    Posted 3 years ago #

    syntax highlighting does not seem to work with either Chrome or IE browser using v3.x Anyone else have this problem? Works fine under v2.3.8.

  2. Garth Gutenberg
    Member
    Posted 3 years ago #

    Same problem here (Chrome anyway, not tested in IE). Chrome's console is throwing the following errors:

    Uncaught SyntaxError: Invalid regular expression: /\w+:\/\/[\w-.\/?%&=:@;]*/: Invalid character range
    shBrushBash.js:52Uncaught TypeError: Cannot read property 'Highlighter' of undefined
    shBrushJScript.js:45Uncaught TypeError: Cannot read property 'Highlighter' of undefined
    shBrushPhp.js:81Uncaught TypeError: Cannot read property 'Highlighter' of undefined
    shBrushXml.js:62Uncaught TypeError: Cannot read property 'Highlighter' of undefined
    shBrushRuby.js:48Uncaught TypeError: Cannot read property 'Highlighter' of undefined
    http://grinninggecko.com/ :456Uncaught TypeError: Cannot read property 'config' of undefined

    I've tried disabling all plugins and the errors persist. Running Twenty Ten theme as well, so it's a pretty vanilla setup.

    Running Chrome 10.0.612.1 dev. The strange thing is that I just checked my version a few days ago and it was 9.0.597.19 dev - and I'm pretty sure it was working then. So it looks like the browser update broke something.

  3. Alex Mills (Viper007Bond)
    Moderator
    Plugin Author

    Posted 3 years ago #

    http://www.viper007bond.com/wordpress-plugins/syntaxhighlighter/ works for me in IE9.

    I know it used to work fine in Chrome, but it does indeed seem broken in the latest Chrome dev build. This is obviously a bug in Chrome. :)

  4. Garth Gutenberg
    Member
    Posted 3 years ago #

    Thanks for the confirmation Alex. I thought I was losing my mind.

  5. Garth Gutenberg
    Member
    Posted 3 years ago #

    Chrome 10.0.612.3 dev fixes the problem (just auto-updated).

  6. Samuel Wood (Otto)
    Tech Ninja
    Posted 3 years ago #

    Even with the latest Chrome (same version as above), I couldn't get SyntaxHighlighter to work. Doesn't even work on the preview piece on the setting screen. Changing options around to use version 2 of the JS code didn't make any difference.

    So I downgraded back to 2.3.2. Again. That one still works perfectly. I have yet to get any of the 3.x versions of SyntaxHighlighter to work properly. This was the second time I tried. :)

    Note: It worked in Firefox. So it's not necessarily an issue with the plugin. Still, if the JS doesn't work in some browsers, then I'd prefer to stick to the older code that has more compatibility. Also, the new version still lacks the toolbar and the click-to-copy button, which I liked.

  7. djevrek
    Member
    Posted 3 years ago #

    This happends to me when my post title have "" in name. When i remove it, everything works just perfect. I hope this will help you to solve title related issues Alex.

  8. Alex Mills (Viper007Bond)
    Moderator
    Plugin Author

    Posted 3 years ago #

    Don't forget that you can toggle what version of the Javascript highlighting package to use on my plugin's settings page.

    I strongly recommend always using the latest version of my plugin. :)

    BTW, http://www.viper007bond.com/wordpress-plugins/syntaxhighlighter/ works fine for me in Chrome v10.0.634.0 dev.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic