WordPress.org

Ready to get started?Download WordPress

Forums

SurveyMe
Weird Message after survey is submitted (21 posts)

  1. glreverb
    Member
    Posted 2 years ago #

    Hello,

    We have our survey up, the only issue that we are having is that once someone hits the submit button, instead of receiving our message that their survey has been submitted they received the following:

    Invalid query: Unknown column 'info[wp_user]' in 'where clause' Whole query: SELECT count(*)+1 'count' FROM wp_surveyme_early_childhood WHERE Your Email Required = 'asdasd@asdasd' OR (info[wp_user]=0 AND info[wp_user]!=-1)

    Could you please help us with this? Thank you! And thanks for this plugin!

    http://wordpress.org/extend/plugins/wp-survey/

  2. DCoda
    Member
    Plugin Author

    Posted 2 years ago #

    This will be looked into, and we'll post an update as required.

  3. DCoda
    Member
    Plugin Author

    Posted 2 years ago #

    HI, we just tested the plugin and every thing worked as expected.
    Can you tell me,

    1. what version of mysql are your using?
    2. is this a new survey or was it created on a previous version of the plugin
    3. also just to be sure, what version of the plugin are you using?
    4. what language is the site in, as sometimes special characters couse problem with saving this to the db.
  4. Woble
    Member
    Posted 2 years ago #

    Hi, I also experience a similar error:
    Invalid query: Unknown column 'info[wp_user]' in 'where clause' Whole query: SELECT count(*)+1 'count' FROM wp_surveyme_aawc_6_2 WHERE (info[wp_user]=0 AND info[wp_user]!=-1)

    I have mySQL 5.1.56

    I upgraded the plugin from the previous version (2.6.41) to the latest 3.0.43

    I tried using both a previous survey as a template, and also creating a new survey from scratch. The error is displayed either way.

    The site is in English - to my knowledge there are no special characters used.

    I notice that:
    If I create a survey, fill out and submit, the following columns are missing:
    info[form_sent], info[wp_user] info[form_received]

    and I get the error.

    If I manually create a table for the survey with the same columns as a previous survey, (i.e. these three columns are present), when I submit, a row is created, but the three columns are NULL.

  5. DCoda
    Member
    Plugin Author

    Posted 2 years ago #

    This is very strange, because to allow the forms to be changed after they are already in use the tables fields are checked and the missing ones are ( but maybe not ) added to the table.

    The two fields you mention are created on the fly so they will be in the form as such.
    we'll get back to you when we've looked into this further.
    Thanks for the input.

  6. DCoda
    Member
    Plugin Author

    Posted 2 years ago #

    The new version has just gone through testing, so please try this to see if it fixes your problem, before we update the documentation and release it.
    http://downloads.wordpress.org/plugin/wp-survey.4.5.45.b.zip

  7. Woble
    Member
    Posted 2 years ago #

    Thanks for your quick response.

    I tried the following:

    Renamed the plugin folder and installed the beta.

    On one page I have text and bb code to link to 8 surveys:
    aawc_6_1 through to aawc_6_8. Each has a field for 'name', 3 text fields, 1 text box and a submit button.

    I made sure no associated tables existed in the database.

    I filled out the first survey and clicked submit.
    However, this creates all 8 tables and adds the record to all 8, instead of just table wp_surveyme_aawc_6_1. All 8 surveys show as 'you have already taken this survey.

    If I then drop all 8 tables wp_surveyme_aawc_6_1 - wp_surveyme_aawc_6_8, they surveys still show as 'already taken this survey'

    When I drop the tables to try again, all

  8. DCoda
    Member
    Plugin Author

    Posted 2 years ago #

    But do i take it your original problem was fixed with this beta?

    This new problem is because you cannot have multiple surveys on one page.

    One survey 1 page.

  9. Woble
    Member
    Posted 2 years ago #

    Yes, thats correct the original issue is now fixed.

    Is the one survey per page intended?
    If so, thats a little frustrating as I'll have to redesign a lot of the blog. I don't see why multiple surveys on a page should be an issue, especially as it worked in previous versions.

  10. DCoda
    Member
    Plugin Author

    Posted 2 years ago #

    Multiple surveys on one page seems a little odd as a survey is usually an entire page in itself, and multiple would be confusing to the user, so the plugin was never written to cater for this.
    If it worked in previous versions then that was not intended and is very surprising.
    The documentation will be updated accordingly.

  11. Woble
    Member
    Posted 2 years ago #

    Ok, thanks. I'm going to try an approach using pages and sub-pages. Will let you know the outcome.

  12. DCoda
    Member
    Plugin Author

    Posted 2 years ago #

    If there is a quick solution to this it will be added.

  13. DCoda
    Member
    Plugin Author

    Posted 2 years ago #

    There is a quick workaround fix. Bear with us and we'll post a new beta soon.

  14. DCoda
    Member
    Plugin Author

    Posted 2 years ago #

    This should allow for multiple surveys that do not interfere with each other.
    http://downloads.wordpress.org/plugin/wp-survey.4.5.45.b3.zip

    This is still a beta, so and the new feature will not be documented until it is released.

  15. Woble
    Member
    Posted 2 years ago #

    I've tested using newly created surveys. Looking much better.

    One annoyance is:

    Scenario with 8 surveys on one page.

    Complete first survey and click submit.
    Data in db table ok.
    Page is refreshed with 'you have already completed this survey' for 1st survey. However surveys 2-8 are populated with the previous surveys' responses. These fields should all be cleared.

    Repeated above by completing 2nd survey. survey 1 and 3-8 are then populated with survey 2 data in the fields.

    I'll also test this beta against some of my previous surveys (which were created using v 2.6.41)
    Thanks.

  16. Woble
    Member
    Posted 2 years ago #

    Just noticed I cannot submit for more than one user.

    1. Submit for surveys 1 and 2 with admin user
    2. Log in as tester user. Cannot submit for surveys 1 or 2. Submit for 3 ok.
    3. Log back in as admin. Cannot submit for 3.

  17. DCoda
    Member
    Plugin Author

    Posted 2 years ago #

    The posting of the data is unfortunate, and it will take us a while to get that cleared up.
    This currently isn;t a priority but its on the list.

    This is a cookie issue. We'll add a fix to the list for a future release. But it is expected that users will be using different browsers.

    For now clear the cookies. And when testing the forms set the cookie duration ( under general ) to something low.

    Even if 1 users is able to submit a survey more than once, it is recored as such in the db.

    Sorry for the hassle.

  18. Woble
    Member
    Posted 2 years ago #

    Thanks.
    Yes, agreed this is not a high priority.

    My comment posted after that will require more attention though, as currently only one user can submit per survey:

    "Just noticed I cannot submit for more than one user.

    1. Submit for surveys 1 and 2 with admin user
    2. Log in as tester user. Cannot submit for surveys 1 or 2. Submit for 3 ok.
    3. Log back in as admin. Cannot submit for 3.
    "

  19. DCoda
    Member
    Plugin Author

    Posted 2 years ago #

    This is not the case, as i said before.
    As long as the users are using different browsers, multiple users can submit a survey.
    This will be fixed in a later release, but as we don't expect everybody to be using the same browser it is not a high priority.

  20. Woble
    Member
    Posted 2 years ago #

    Apologies, I misunderstood.

    Yes, it works fine with different browsers for now.

    Thanks for the quick fixes!

  21. DCoda
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks for your feedback.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags