WordPress.org

Ready to get started?Download WordPress

Forums

Supra CSV
[resolved] Problem ingesting file (19 posts)

  1. JasonBC
    Member
    Posted 1 year ago #

    Using ver. 2.5.1- I'm not sure why my file has a problem ingesting, I get this message for all 475 records:
    Sorry, one of the given taxonomies is not supported by the post type.Problem Ingesting

    My file is pretty straighforward with fields like: property,city, country, website, featured, active.
    It discovers my post type just fine. City and country are preset as category type taxonomies. I checked on "parse complex categories". Those taxonomies are not detected with the post meta suggestions so that's probably part of the problem, but I don't know where I'm going wrong.

    http://wordpress.org/extend/plugins/supra-csv-parser/

  2. Joseph Persie
    Member
    Plugin Author

    Posted 1 year ago #

    turn on debug ingestion in the configuration tab and paste the output here make sure its only for the first three posts

  3. Joseph Persie
    Member
    Plugin Author

    Posted 1 year ago #

    In the newest version i have provided issue reporting which sends me an email of the debug output when you check the issue reporting checkbox in the configuration tab. the debug output will notify whether or not the issue has been successfully reported

  4. Joseph Persie
    Member
    Plugin Author

    Posted 1 year ago #

    this problem has been fixed in the latest version, thanks for beta testing

  5. JasonBC
    Member
    Posted 1 year ago #

    I'm trying again with your latest update. It's still not seeing my taxonomies in the detection stage or during ingestion in the "custom terms" section. The mapping preset on the righthand side of the ingestion screen doesn't show any choices even after I created a preset. I created my custom post type with the "Types" plugin.

    Perhaps if I had an example of how the taxonomies should be setup, then I'd understand the process better. It seems like the instructions for this were left incomplete. It takes a very long time >30 minutes to inject a 480 line file, is that normal?

  6. Joseph Persie
    Member
    Plugin Author

    Posted 1 year ago #

    quick google search: "d fields lets you do things that no other custom-fields plugin can do. ... Types custom fields use the standard WordPress post-meta"

    because the types plugin chose to deviate from the wordpress convention this plugin is incompatible with your custom post type records.

  7. Joseph Persie
    Member
    Plugin Author

    Posted 1 year ago #

    create a new post of the custom post type and provide all possible values, this will give you suggested post meta values to conform to.

  8. Joseph Persie
    Member
    Plugin Author

    Posted 1 year ago #

    if this is the same plugin than it should support postmeta convention:
    http://wordpress.org/extend/plugins/types/

  9. JasonBC
    Member
    Posted 1 year ago #

    Yeah, that's the plugin. It's been doing the ingestion process for over an hour. It didn't take this long before.

  10. Joseph Persie
    Member
    Plugin Author

    Posted 1 year ago #

    provide the csv file so i can test it

  11. akallus
    Member
    Posted 1 year ago #

    Thx for oppty to post on the support forum.

    For me, the plugin isn't able to complete the ingestion process. (The program keeps "thinking"). I suspect this is because I've uploaded a file that is somehow broken. Here are the errors that I see when I preview the uploaded file:

    fgetcsv() expects at most 4 parameters, 5 given in /home/kaker/public_html/gearlisted.com/wp-content/plugins/supra-csv-parser/classes/UploadCsv.php on line 122

    Warning: implode() [function.implode]: Invalid arguments passed in /home/kaker/public_html/gearlisted.com/wp-content/plugins/supra-csv-parser/classes/UploadCsv.php on line 125

    Warning: fgetcsv() expects at most 4 parameters, 5 given in /home/kaker/public_html/gearlisted.com/wp-content/plugins/supra-csv-parser/classes/UploadCsv.php on line 122

  12. Joseph Persie
    Member
    Plugin Author

    Posted 1 year ago #

    what do you have for csv settings at the bottom of the configuration page?

  13. akallus
    Member
    Posted 1 year ago #

    delimiter:,
    enclosure:"
    escape:\

    These are the default settings I believe. Maybe this should be tab delimited??

    Tx.

  14. Joseph Persie
    Member
    Plugin Author

    Posted 1 year ago #

    update to php 5.3 this should fix the problem

  15. Joseph Persie
    Member
    Plugin Author

    Posted 1 year ago #

    try version 2.7.2 it prevents from having to upgrade php

  16. akallus
    Member
    Posted 1 year ago #

    I tried this. Initially, I was getting another error, which suggested that I needed to change my WordPress XML Settings (Writing Settings). I'm still having some problems with the fields, but I suspect that I can resolve that by playing with the mapping, etc.

    Thanks for the tip!

  17. akallus
    Member
    Posted 1 year ago #

    Thanks again for providing such great support.

    I’m still having trouble ingesting several fields correctly. In some cases, I suspect that the problem is related to customizations that I’ve had made to the WP theme. However, in other cases, I don’t know what the problem is. For instance, I’ve created a field in my csv that instructs the theme to “hide ranking” for a line within the CSV. “Hide ranking” is visible in “post info”, so it should theorectically be easy to suppress showing rankings by entering “true” in the “hide ranking column”… but it’s not working. The rankings continue to appear. When I go to edit the page, neither "show" nor "hide" radio buttons are engaged. Is this a theme issue? Or something that can be addressed via the plugin?

    I have some more questions about custom taxonomies later, but I thought I’d start with the easier one. Thx again for the help.

  18. Joseph Persie
    Member
    Plugin Author

    Posted 1 year ago #

    hide ranking may have an undersore in between also try other booolean vales such as 1. there is not much i can do to debug this since it is related to a custom theme and not the plugin or the wordpress core

  19. Joseph Persie
    Member
    Plugin Author

    Posted 1 year ago #

    to further troubleshoot the issue provide a screenshot of the postmeta suggestions. You could also provide development access to the application.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.