WordPress.org

Ready to get started?Download WordPress

Forums

SuperSlider-Media-Pop
[resolved] Featured Image, still showing full size in post edit (13 posts)

  1. brasofilo
    Member
    Posted 2 years ago #

    it's the same issue pointed last year (three posts bellow this)

    considering that the domain wp-superslider.com ain't active, maybe this plugin is not being supported anymore... (?)

    http://wordpress.org/extend/plugins/superslider-media-pop/

  2. brasofilo
    Member
    Posted 2 years ago #

    tried to track down the bug, but ended up with this brute force solution
    add this to the admin css
    .attachment-post-thumbnail { width: 255px; height: 175px; }

  3. Daiv Mowbray
    Member
    Plugin Author

    Posted 2 years ago #

    Hello brasofilo
    This issue has been addressed with the latest (1.6.1) update.
    Fixed a bug with the post list thumbnail image display.

    Let me know if this isn't the case.
    Thanx.

    Daiv

  4. brasofilo
    Member
    Posted 2 years ago #

    hi Daiv,
    I've just updated the plugin in one test-site (before doing it live), and the size of the featured image is ok now in the post/page editing window (post.php).
    [edit: sorry, further tests show the problem persists]

    But strangely enough some are displaying distorted in the listing page (edit.php).

    Screenshot

    the normal thumb prints this
    <img width="55" height="55" src="http://iris:8888/media/i3-100x100.jpg" class="attachment-55x55" alt="" title="">

    the distorted one prints this and does have a 100x100 version in the uploads folder:
    <img width="956" height="637" src="http://iris:8888/media/according.jpg" class="max-width:55" alt="" title="">

    Thanks for your support!

  5. brasofilo
    Member
    Posted 2 years ago #

    I guess I should add that 100x100 is the Thumbnail size as defined in options-media.php

    And in my functions.php I have this:

    add_theme_support( 'post-thumbnails' );
    set_post_thumbnail_size( 105, 105, true );
    add_image_size( 'header-images', 430, 255, false );
    add_image_size( 'page-images', 215, 0, false );
    add_image_size( 'index-images', 140, 140, true );

    I used the plugin Regenerate Thumbnails every time I added a new size, so all sizes are present in the uploads folder.

  6. Daiv Mowbray
    Member
    Plugin Author

    Posted 2 years ago #

    Have you tried doing a thumbnail rebuild?
    sometimes the file size is unavailable because of changes to your sizes.Confirm that the proper file is on the server, and or use the rebuild thumbnail plugin to rebuild.

  7. brasofilo
    Member
    Posted 2 years ago #

    Sorry, I haven't said plainly, but yes I did a full thumbs rebuild and all sizes are present.
    - I've disabled all plugins and activated TwentyEleven, but Featured Images keep distorted and Attached Images don't

    I'm running this in a MAMP localhost and haven't tested on a live site yet.
    I imagine that you are not being able to reproduce this, right?

    I'll try to do the update on a live site and get back...

  8. spherical
    Member
    Posted 2 years ago #

    The code differences that brasofilo noted are at least part of the problem. Specifying:

    class="max-width:'.$thumb_size.';"

    is wiping out the attachment-NNxNN class that normally goes in there; which is what was making the images on the posts screen the correct size. Where the plugin is getting the pixel dimensions of the full size images from is beyond me but, in the case of images that are a part of Post Formats; which don't necessarily have post thumbnails, parsing any image that the post has as an attachment and assuming that it is a pre-sampled thumbnail is an assumption that should, IMO, not be made.

    In addition, the page code for it is generated thus:

    class="&quotmax-width:64;&quot"
    (";" omitted from &quot because the entity gets converted in here)

    Clearly not validatable HTML.

    There's probably other stuff in the mix; such as compatibility with plugins such as Get-the-Image that are employed do a lot of the image display.

    Then, line 215 has me puzzled:

    <input name="ss_admin_thumb" id="ss_admin_thumb" type="text" value="'. $thumb.'" class="small-text" /> px';

  9. Daiv Mowbray
    Member
    Plugin Author

    Posted 2 years ago #

    Ok fellas,
    I was finally able to reproduce this error.
    And fix it.
    Thanx spherical for noting the typo, where it said class, it should have been style.
    Please update to version 1.7
    and let me know if your issues have been resolved.
    My apologies for the delay and for the problem to start with.

    HTH.

    By the way check out my new plugin:
    superslider-perpost-code

  10. brasofilo
    Member
    Posted 2 years ago #

    hi Daiv, thanks for your support

    i'm sorry to say that the problem is solved in edit.php but remains in post.php
    :/

  11. Daiv Mowbray
    Member
    Plugin Author

    Posted 2 years ago #

    Hello brasofilo,
    Thanx for the feadback.
    I am trying to reproduce your issue.

    Solved in edit.php would refer to the thumbnail column on the post listing screen. The thumb size is responding as expected.

    Issue remains in edit.php would refer to the edit the individual post screen, specifically the featured image display size in the featured image meta box.

    If this is correct, I am unable to reproduce the error.
    also, the plugin superslider-media-pop doesn't have anything to do with the featured image. Except on the post listing screen, where it displays the featured image if the post has one, and says so as a caption to the image, other wise the caption says if the image is an attached image. If the post has no image, the caption is Add image, which ultimately I would like to have launch a pop over access to the media library.

    So, I either don't understand the present issue, or the issue has nothing to do with ss-media-pop.

    Thanx again for your assistance.

  12. brasofilo
    Member
    Posted 2 years ago #

    hi Daiv,
    yes, that is correct, I'm referring to wp-admin/edit.php (all posts) and wp-admin/post.php?post=98&action=edit (post editing).

    My test is:
    - disable all plugins, except ss-media-pop
    - swap to default theme, Twenty Eleven

    The result is quite curious...
    1) with ssmp active the Featured Image Meta Box prints

    <p class="hide-if-no-js"><a title="Establecer la imagen destacada" href="http://localhost:8888/wp-admin/media-upload.php?post_id=98&type=image&TB_iframe=1&width=640&height=305" id="set-post-thumbnail" class="thickbox"><img width="1000" height="750" src="http://localhost:8888/wp-content/uploads/2012/03/cesto3.jpg" class="attachment-post-thumbnail" alt="cesto3" title="cesto3"></a></p>

    2)if I disable it, the metabox prints

    <p class="hide-if-no-js"><a title="Establecer la imagen destacada" href="http://localhost:8888/wp-admin/media-upload.php?post_id=98&type=image&TB_iframe=1&width=640&height=305" id="set-post-thumbnail" class="thickbox"><img width="266" height="199" src="http://localhost:8888/wp-content/uploads/2012/03/cesto3.jpg" class="attachment-post-thumbnail" alt="cesto3" title="cesto3"></a></p>

    They are pulling exactly the same full sized image, but one is resized and the other not...
    So, a WP default configuration simply resizes the big image into the metabox, and it's no big deal to put an extra css in wp_head to hard resize or some jQuery to proportional resize.

    I suppose there's some side effect occurring in my configurations.
    This is happening localhost (mac osx 10.6, mamp 1.9) and online (vps linux).
    The only thing I can think of is wp-config.php, mine has this extra stuff:

    define( 'WPLANG', 'es_ES' );
    define('DISALLOW_FILE_EDIT', true);
    define('WPCOM_API_KEY','key_number');

    thanks

  13. Daiv Mowbray
    Member
    Plugin Author

    Posted 2 years ago #

    Hello people, I have just updated this plugin to version 1.8
    which does resolve the featured image issues mentioned above.
    It also now has a better solution for the attachments listing on the post / page listing screen, the attachments is a fold down which helps a lot when you have numerous attachments on a post or page.

    I have tested this extensively on new and old installs with no issues to my knowledge.

    please correct me if I missed something.

    Thanks,
    Daiv

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic