WordPress.org

Ready to get started?Download WordPress

Forums

Subscribe2
[resolved] You do not have sufficient permissions to access this page. (10 posts)

  1. iobserve
    Member
    Posted 2 years ago #

    Hi,

    When I click the options 'Subscribers', 'Settings', or 'Send Email', I get the error: 'You do not have sufficient permissions to access this page.'.

    This is strange. I'm administrator. This was never a problem before. Is this caused by an update to the 3.3.x version?

    How can I resolve this? I really do not want to loose my subscribers...

    Cheers,

    Koen

    http://wordpress.org/extend/plugins/subscribe2/

  2. mattyrob
    Member
    Plugin Contributor

    Posted 2 years ago #

    @Koen,

    Are you using the most recent version of Subscribe2 (8.2) ?

  3. iobserve
    Member
    Posted 2 years ago #

    Yes, 8.2

  4. mattyrob
    Member
    Plugin Contributor

    Posted 2 years ago #

    @Koen,

    Are you using any Registration or Members plugins?

  5. iobserve
    Member
    Posted 2 years ago #

    Not that I know of... These are my plugins (all up-to-date):

    Akismet
    DM Albums
    Publish 2 Ping.fm
    Subscribe2
    The Events Calendar
    Twitter for WordPress
    Wordpress.com Stats
    WP-Cumulus
    WP-PostViews

  6. mattyrob
    Member
    Plugin Contributor

    Posted 2 years ago #

    @Koen,

    In the classes folder for the plugin you should find a file called classes-s2-admin.php. At the top of this is a function called admin_menu() and it looks like this:

    add_menu_page (__('Subscribe2', 'subscribe2'), __('Subscribe2', 'subscribe2'), apply_filters('s2_capability', "read", 'user'), 's2', NULL, S2URL . 'include/email_edit.png');
    
    $s2user = add_submenu_page('s2', __('Your Subscriptions', 'subscribe2'), __('Your Subscriptions', 'subscribe2'), apply_filters('s2_capability', "read", 'user'), 's2', array(&$this, 'user_menu'), S2URL . 'include/email_edit.png');
    add_action("admin_print_scripts-$s2user", array(&$this, 'checkbox_form_js'));
    add_action("admin_print_styles-$s2user", array(&$this, 'user_admin_css'));
    
    $s2subscribers = add_submenu_page('s2', __('Subscribers', 'subscribe2'), __('Subscribers', 'subscribe2'), apply_filters('s2_capability', "manage_options", 'manage'), 's2_tools', array(&$this, 'subscribers_menu'));
    add_action("admin_print_scripts-$s2subscribers", array(&$this, 'checkbox_form_js'));
    
    $s2settings = add_submenu_page('s2', __('Settings', 'subscribe2'), __('Settings', 'subscribe2'), apply_filters('s2_capability', "manage_options", 'settings'), 's2_settings', array(&$this, 'settings_menu'));
    add_action("admin_print_scripts-$s2settings", array(&$this, 'checkbox_form_js'));
    add_action("admin_print_scripts-$s2settings", array(&$this, 'option_form_js'));
    add_filter('plugin_row_meta', array(&$this, 'plugin_links'), 10, 2);
    
    add_submenu_page('s2', __('Send Email', 'subscribe2'), __('Send Email', 'subscribe2'), apply_filters('s2_capability', "publish_posts", 'send'), 's2_posts', array(&$this, 'write_menu'));
    
    $s2nonce = md5('subscribe2');

    Try replacing that code with the following:

    add_menu_page (__('Subscribe2', 'subscribe2'), __('Subscribe2', 'subscribe2'), "read", 's2', NULL, S2URL . 'include/email_edit.png');
    
    $s2user = add_submenu_page('s2', __('Your Subscriptions', 'subscribe2'), __('Your Subscriptions', 'subscribe2'), "read", 's2', array(&$this, 'user_menu'), S2URL . 'include/email_edit.png');
    add_action("admin_print_scripts-$s2user", array(&$this, 'checkbox_form_js'));
    add_action("admin_print_styles-$s2user", array(&$this, 'user_admin_css'));
    
    $s2subscribers = add_submenu_page('s2', __('Subscribers', 'subscribe2'), __('Subscribers', 'subscribe2'), "manage_options", 's2_tools', array(&$this, 'subscribers_menu'));
    add_action("admin_print_scripts-$s2subscribers", array(&$this, 'checkbox_form_js'));
    
    $s2settings = add_submenu_page('s2', __('Settings', 'subscribe2'), __('Settings', 'subscribe2'), "manage_options", 's2_settings', array(&$this, 'settings_menu'));
    add_action("admin_print_scripts-$s2settings", array(&$this, 'checkbox_form_js'));
    add_action("admin_print_scripts-$s2settings", array(&$this, 'option_form_js'));
    add_filter('plugin_row_meta', array(&$this, 'plugin_links'), 10, 2);
    
    add_submenu_page('s2', __('Send Email', 'subscribe2'), __('Send Email', 'subscribe2'), "publish_posts", 's2_posts', array(&$this, 'write_menu'));
    
    $s2nonce = md5('subscribe2');

    Does that help?

  7. iobserve
    Member
    Posted 2 years ago #

    Thanks MattyRob, I've replaced the code.
    Still the same message though...

  8. mattyrob
    Member
    Plugin Contributor

    Posted 2 years ago #

    @Koen,

    Okay, well that's excluded one problem. Can you temporarily deactivate your other plugins (expect Akismet - I know that one's okay) and see if it starts to work if Subscribe2 is the only active plugin.

    Also, try using one of the default themes for a minute and see if that helps.

  9. iobserve
    Member
    Posted 2 years ago #

    Ah! Solved! Or at least: a work-around is found!

    When I deactivated all the plugins I could access the 'Subscribers', 'Settings', or 'Send Email' screens again! Then I activated them one by one, testing if I would still have access. When I activate 'Publish 2 ping.fm' the problem returns.

    Thanks for your help! What's the next step? Should this be resolved in Publish 2 ping.fm or in Subscribe2?

    Cheers!!

  10. mattyrob
    Member
    Plugin Contributor

    Posted 2 years ago #

    @Koen,

    It seems for checking on the ping.fm site that it is being closed down and replaced with seesmic soon. In fact they are talking about a June close down.

    With that in mind I'd suggest you find a different social network plugin.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags