WordPress.org

Ready to get started?Download WordPress

Forums

Subscribe2
[resolved] Subscribers dont show up (12 posts)

  1. decca1o
    Member
    Posted 1 year ago #

    Hello, using both the widget and a dedicated page, I was not able to see any of the test email addresses I entered. Is there anything I need to do besides install & activate the plugins? I am looking for the emails to show up in the subscribers admin page under the subscriber 2 section. I appreciate your help.

    http://wordpress.org/extend/plugins/subscribe2/

  2. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @decca1o,

    These address you have entered should be present in the Subscribe2->Subscribers page if you filter on Unconfirmed under Public Subscribers.

  3. decca1o
    Member
    Posted 1 year ago #

    Yeah, that is what I expected too, but they are just not there.

  4. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @decca1o,

    What if you try adding them from the admin area in the section at the top of that page?

    When you try adding from the front side form or widget what message do you get after hitting "Subscribe".

  5. decca1o
    Member
    Posted 1 year ago #

    yeah that one works when I add it from the admin.

    After trying the other options it loads the home page.

  6. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @decca1o,

    You probably need to visit Subscribe2->Settings and also the Widget page and the settings in the Subscribe2 Widget and update the Subscribe2 page to point the returned data to the WordPress page you wrote to handle subscriptions then, rather than it directing to your site home page.

  7. dennis93q
    Member
    Posted 1 year ago #

    I'm having the same problem.

    I just created a "thank you" page, but obviously your post above indicates that it's more than that. I have to create a "wordpress page to handle subscriptions?"

    How is this done? Where in the documentation is this?

  8. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @dennis93q,

    It's step 7 here in the installation instructions.

  9. dennis93q
    Member
    Posted 1 year ago #

    I've now done that and abandoned the widget, but it's still not working.

    I put in an email address and click subscribe, and it goes right back to the same "subscribe" form. Nothing seems to happen....

  10. decca1o
    Member
    Posted 1 year ago #

    Thanks dennis93q, that did the trick for me.

    Any idea what I need to do to get the widget to match the styling of all the other widgets? It does not pick up the background style like all the other widgets do. I appreciate the help.

  11. dennis93q
    Member
    Posted 1 year ago #

    decca - what did you do to get it to work? i created a page with the shortcode in it on a line by itself.... but it doesn't work. what's your URL? can i see how you got it to work?

  12. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @decca1o,

    To style the Widget open up the settings and add the correct DIV name to the settings like the one used by your other Widgets.

    @dennis93q,

    When you say you've created a page with the shortcode and "it doesn't work", can you be a little more descriptive? What exactly is happening on your screen and what are you expecting to see?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags