WordPress.org

Ready to get started?Download WordPress

Forums

Subscribe2
Subscribed categories preferences lost (6 posts)

  1. marpa
    Member
    Posted 3 years ago #

    Subscribed categories preferences for one blog get deleted when preferences are updated on another blog on WordPress 3.0.1. Here are steps to recreate on blogs that have the plugin activated:

    1. Go to Dashboard > Users > Your subscriptions
    2. Chose to select all (or just some) categories and update preferences
    3. Go to the Dashboard of another blog that has the Subscribe2 plugin
      activated
    4. Go to Users > Your subscriptions
    5. Chose to select all (or just some) categories and update preferences
    6. Return to original blog Dashboard > Users > Your subscriptions

    This problem occurs on the current version of the plugin (5.9) as well as the
    latest version (6.0)

    http://wordpress.org/extend/plugins/subscribe2/

  2. mattyrob
    Member
    Plugin Contributor

    Posted 3 years ago #

    @marpa,

    Try the development version, this contains fixes for multiuser sites, which it sounds like you are using since you are talking about blogs in the plural form.

  3. marpa
    Member
    Posted 3 years ago #

    @MattyRob,
    Development version (6.1) works with our WP 3.0.1 multiuser instances. Specifically, settings from one blog are now no longer overridden by settings from another blog. In addition, Users > Your Subscriptions now shows subscribed blogs and blogs to subscribe to.

    Issues with this version that we found:
    -display of site description when hovering over site title doesn't work consistently and when it does it obscures site title in row above

    Otherwise seems to work fine. Any reason we can't use this code in production?

  4. mattyrob
    Member
    Plugin Contributor

    Posted 3 years ago #

    @marpa,

    You can use that code on production site if you like, just be careful that the trunk has not changed as it is evolving code and while it may fix some issues, by adding new features and bug fixes it can introduce whole new ones!

  5. Jason Lemahieu (MadtownLems)
    Member
    Posted 3 years ago #

    From my experiences, 6.0 works fairly well on fresh 3.0 installs turned into MultiSite - but NOT on wpmu upgraded sites.

    marpa - were you a wpmu upgraded site?

    mattyrob - thanks again for your hard work

  6. marpa
    Member
    Posted 3 years ago #

    I was mistaken! My apologies. 6.0 is working properly on our instance of WordPress (3.0.1) configured as multi-site. The UI for managing Subscribed Blogs needs a bit of work, but otherwise seems to be functional. We update it in our production instance and let you know if we discover any other issues.

    Thanks for your help

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags