WordPress.org

Ready to get started?Download WordPress

Forums

Subscribe2
[resolved] Subscribe form not working (3 posts)

  1. jillbilly
    Member
    Posted 1 year ago #

    i'm not even sure if this a Subscribe2 issue, but my client's subscribe form was working fine up until recently. she just noticed yesterday it wasn't working. when you enter your email and click the 'subscribe' or 'unsubscribe' button, you get a 501 error...

    501 Not Implemented
    We are sorry to be unable to perform the method POST at this time or to this document.

    neither of us has touched the wordpress admin in weeks. today i updated the plugin thinking it might help but no luck.

    i'm not an expert developer so if you could provide any feedback/help using dumbed-down vocabulary, i'd appreciate it! =o)

    http://wordpress.org/extend/plugins/subscribe2/

  2. mattyrob
    Member
    Plugin Author

    Posted 1 year ago #

    @jillbilly,

    I'm willing to bet that at some point the web server software on your server has been updated or re-compiled (probably by your hosting provider).

    Essentially, when this was done the POST method was not enabled. This article may explain a little more for you.

    To resolve this you need to raise this with the hosting provider.

  3. jillbilly
    Member
    Posted 1 year ago #

    thank you for the quick response MattyRob! i called the hosting company and they said nothing had changed. however, a friend suggested it might be a URL rewrite issue and had me change the permalinks to the default setting instead of the custom setting we had been using. that did the trick! so ultimately, not a Subscribe2 issue and i still don't know for sure what happened, but at least we have it working again.

    thanks again!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic