WordPress.org

Ready to get started?Download WordPress

Forums

Subscribe2
[resolved] "subscribe" doesn't work (9 posts)

  1. mjwillis
    Member
    Posted 1 year ago #

    New people are unable to subscribe. When they enter their email address and hit "subscribe" it takes them to another page on my site and no email notification is sent to them nor to me. They don't get subscribed.

    http://wordpress.org/extend/plugins/subscribe2/

  2. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @mjwillis,

    You probably don't have the Subscribe2 code running on the page you are re-directing to. Either make sure the Sidebar is on that page with the WordPress widget there or put the [subscribe2] shortcode into the body of that page.

  3. scarpenter
    Member
    Posted 1 year ago #

    Hi -- created a page named "email-subscription", containing the <--subscribe2--> comment on its own line, with blanks above and below it. When I display the page, I get the form to enter an email address, click submit, and then get redirected to the root of my web site, although I have set the email subscription page in the appearance settings. I don't get any other feedback, and my email isn't saved. (The behavior I'd expect is to see some confirmation that the email address was received and a confirmation email would be sent.) Email works from my WordPress installation, since I have WP set to email me for comments. Just wondering if anything else I might look at? I've removed the plugin for now, so I'm not offering a site link, but I'd be willing to give it another go if I can get a lead. I'm guessing it's some dumb thing I'm doing or not doing.

    Thanks!

  4. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @scarpenter,

    You seem to have done everything right and what you are expecting to happen is what is supposed to happen.

    I can only think it's a theme or plugin conflict issue where the plugin output is being re-directed to the front page for some reason. Try disabling all other plugins and if it still fails try a core WordPress theme. Then back track from that (hopefully) working position until things break to find the conflict culprit.

  5. mjwillis
    Member
    Posted 1 year ago #

    BTW - Mattyrob - Thanks you for your previous response. It worked!!!!

  6. zoominity
    Member
    Posted 1 year ago #

    I just installed subscriber 2. I use a mac.
    A- I cannot see any checkboxes that will allow me to subscribe to a specific page. I only see and email address option with a subscribe and unsubscribe button.
    B- I'm testing a new email address "x@gmail.com" to see if I'm getting a new subscriber, and it does not seem to work.
    I tried monkeying around for 1 hour trying different configurations in the settings and am getting nowhere. Is there something in the settings that I'm not getting?
    C- Unless there is a solution to this problem, an anyone recommend a less corrupted plugin?
    Thanks

  7. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @zoominity,

    I use a Mac to develop the plugin and it works as expected for me.

    A- I'm not sure what you mean by "I cannot see any checkboxes that will allow me to subscribe to a specific page." This plugin is not for subscribing to updates or comments in a specific page, it sends email notifications for future, new posts.

    B- Are you using the "x@gmail.com" to try to subscribe? Has it shown un under Unconfirmed Subscribers in the Subscribe2->Subscribers page? Are you getting any error messages? Any warning messages from the plugin? Do you already get emails for things like new user registrations and comments? If not them emails are not working on your site already.

    C- If you think the files are corrupted then re-upload them. If you don't think the plugin is working please try and be more descriptive about the issue and less insulting.

  8. CiciBianca
    Member
    Posted 1 year ago #

    I am having trouble with the email subscription on my blog and I cannot figure out what I am doing wrong. When i put in one of my email addresses there is no conformation sent back that I have subscribed. I was using Jetpack subscription but didn't like the fact it was emailing the entire post rather than a link to it. I am a complete novice at this and could really use some help.

  9. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @CiciBianca,

    Is seems that your site is totally ignoring the form posted data. That could be a theme or plugin conflict or even down to server misconfiguration.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags