WordPress.org

Ready to get started?Download WordPress

Forums

Subscribe2
Notification Email "To" email address is wrong (7 posts)

  1. venntom
    Member
    Posted 2 years ago #

    Hi,

    Although the notification email is sent out to the correct subscriber, the "To" emailadress on the received email is wrongly set to the admin emailadress.

    Solution?
    Thx -

    http://wordpress.org/extend/plugins/subscribe2/

  2. venntom
    Member
    Posted 2 years ago #

    Looking at the source code of the email I noticed that:
    "Envelope-To" is set to the subscriber email adress
    "To" is set to the admin email address
    Hope this helps in diagnosing this issue quickly.

  3. venntom
    Member
    Posted 2 years ago #

    Further testing revealed that the issue does only occur with "Restrict the number of recipients per email to (0 for unlimited): 0".
    When I set this to 1, the email "to" value is correct.
    Suspect this issue is caused somewhere in the BCC header construction?

  4. mattyrob
    Member
    Posted 2 years ago #

    @Venntom,

    If you are using a number of recipients other than 1 then the email address is sent to the admin sender and recipients are copied to the BCC header by the plugin.

    Subscribe2 does not form the 'Envelope-To', this must be being done on your server for each of the recipients.

    If setting the number of recipients to 1 works, this is because the emails are sent direct to each recipient thereby removing the BCC header from usage. I suspect the BCC headers are not being correctly handle on your server.

  5. venntom
    Member
    Posted 2 years ago #

    @MattyRob:

    Thanks for your quick reply.

    I figured that your plugin is working as designed when sending the emails with the recipients flag set to 0 (using BCC).

    But would it be difficult to add the feature to set to "To" email adress in that case to an email address we can set ourselves? (for example noreply@xxx.xx)

    Regards,

  6. mattyrob
    Member
    Posted 2 years ago #

    @Venntom,

    Add a new WordPress User account on your site with your specified email address. Then visit Settings->Subscribe2 and choose that account to be your sending account in the drop down list.

  7. venntom
    Member
    Posted 2 years ago #

    @MattyRob,

    Thanks, I have now set it up that way.
    Not sure whether it is optimal that this needs to be a user account with administrator role...otherwise it does not appear in the dropdown box to set the sending account.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags