WordPress.org

Ready to get started?Download WordPress

Forums

Subscribe2
Not working in blog pages (11 posts)

  1. ridclubmba
    Member
    Posted 2 years ago #

    Hi,

    First of all, thanks for this useful plugin.

    I'm using it as a widget in my blog sidebar. This sidebar is in my main blog page, as well as in every blog entry. However, while the plugin works fine in the main blog page, it doesn't in the blog entries.

    You can see the problem in the following links:

    - Main blog page: http://www.club-mba.com/blog (see right sidebar, under the tag cloud)
    - Example of a blog entry: http://www.club-mba.com/2011/07/26/descubriendo-ie-business-school/ (the same sidebar but here it shows "[suscribe2]"

    Any idea what's going on?
    Thanks for the help.

    ridclubmba

  2. mattyrob
    Member
    Plugin Contributor

    Posted 2 years ago #

    @ridclubmba,

    I suspect this is an issue somewhere in your theme. Try using the TwentyEleven theme and see if the problem persists, if not then it is your theme.

    I cannot reproduce this issue myself on my Theme or in TwentyEleven.

    Basically, the single page is, for some reason, not calling the WordPress do_shortcode() function. It is possible the on single pages your theme is not including all the WordPress files that it should be.

  3. ridclubmba
    Member
    Posted 2 years ago #

    Hi MattyRob,

    Thanks for your reply. I resolved the issue by using the WordPress › Subscribe2 Widget-hack, perhaps there is some kind of conflict with other plugin.

    I have another question, it is possible to change the language of the text shown in the widgets? For example, instead of "Subcribe/Unsubscribe", or "Your email" to put the equivalent in Spanish or other language. I see that the email text can be edited from Admin panel, but it is not the case for the widget text.

    Thanks

  4. mattyrob
    Member
    Plugin Contributor

    Posted 2 years ago #

    @ridclubmba,

    It is possible to translate those strings using a get text translation. You can access them here. Upload the *.mo file to the wp-content/plugins/subscribe2/ folder on your server and the language strings for the entire plugin should appear in your chosen language. You may need to set your language code in wp-config.php too though.

  5. ridclubmba
    Member
    Posted 2 years ago #

    Thanks MattyRob, I'll try that.

  6. ridclubmba
    Member
    Posted 2 years ago #

    the language works fine with the Subscribe2 widget, but it doesn't with the s2widgethack widget which I need to use due to the previous issue :(

  7. mattyrob
    Member
    Plugin Contributor

    Posted 2 years ago #

    @ridclubmba,

    If you can't make the default widget work and can only use the hack successfully on your site then your only option for translation is to edit the widget hack file and put the correct phrases into the code yourself. I've had a quick look at the hack widget and the strings are not i18n enabled, so they cannot be dynamically translated.

  8. ridclubmba
    Member
    Posted 2 years ago #

    Did it, thanks. It's not the cleanest solution but at least it works.
    Thanks a lot!!

  9. sergimenez
    Member
    Posted 2 years ago #

    could you tell me please where I have to place the folder. mo. po I have placed in the root, in the lang folder and not working. thanks

  10. mattyrob
    Member
    Plugin Contributor

    Posted 2 years ago #

    @sergimenez,

    Place the .mo file into the plugin folder at wp-content/plugins/subscribe2/. The .po file is not used by the server, it is the human readable form that is compiled by get text into the mo file.

  11. sergimenez
    Member
    Posted 2 years ago #

    thank you very much for the clarification. Now if that works.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags