WordPress.org

Ready to get started?Download WordPress

Forums

Subscribe2
[resolved] New Subscribers Receiving Error (4 posts)

  1. jkcarroll
    Member
    Posted 2 years ago #

    When new subscribers enter their email address on the subscribe2 widget on my blog they are redirected to a page that says "page not found". They do not get a confirmation email and therefore cannot confirm their subscription. I only found this out because someone emailed to let me know about the problem. I was able to replicate it. The users do show up on the admin side, I just have to approve them before they receive the emails. Any idea on how to fix this issue?

    http://wordpress.org/extend/plugins/subscribe2/

  2. mattyrob
    Member
    Posted 2 years ago #

    @jkcarroll,

    Have a step though the install instructions:

    1. Log in to your WordPress blog and visit Plugins->Add New.
    2. Search for Subscribe2, click "Install Now" and then Activate the Plugin
    3. Click the "Settings" admin menu link, and select "Subscribe2".
    4. Configure the options to taste, including the email template and any categories which should be excluded from notification
    5. Click the "Tools" admin menu link, and select "Subscribers".
    6. Manually subscribe people as you see fit.
    7. Create a [WordPress Page](http://codex.wordpress.org/Pages) to display the subscription form. When creating the page, you may click the "S2" button on the QuickBar to automatically insert the subscribe2 token. Or, if you prefer, you may manually insert the subscribe2 shortcode or token: [subscribe2] or the HTML invisible <!--subscribe2--> ***Ensure the token is on a line by itself and that it has a blank line above and below.***
    This token will automatically be replaced by dynamic subscription information and will display all forms and messages as necessary.
    8. In the WordPress "Settings" area for Subscribe2 select the page name in the "Appearance" section that of the WordPress page created in step 7.

    I suspect that you have either not created a WordPress page or Subscribe2 is not liked to the correct page.

  3. jkcarroll
    Member
    Posted 2 years ago #

    This did the trick, thanks! One more question if you have the time. I created a page and inserted the token. The page now shows up on my top navigation bar. I tried to make it private, but then it causes me to get the page not found error. Is there a simple way to make a page, but not make it show up on the nav bar? Thanks again for the quick help!

  4. mattyrob
    Member
    Posted 2 years ago #

    @jkcarroll,

    You probably need to edit or theme or change some settings to exclude that page from being displayed in the navigation bar.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.