WordPress.org

Ready to get started?Download WordPress

Forums

Subscribe2
[resolved] Error Message: "Error On The Server" (42 posts)

  1. Lutz.H
    Member
    Posted 2 years ago #

    Hello!

    I'm using WP 3.4 with Subscribe2 V8.3 and the widget V1.1.
    I'm installing the service for the first time on a news website ... and I'm not a technical pro ... :((

    I set up the plugin and pushed the widget to the site. The "subscribe" button appears and I can send an mail address - but after that always appears an error message "Error On The Server"!

    The mail address is sent and shows up in the subscribor's list, but there is no activating mail sent, so the subscription is not complete.

    I really do hope you can help me fixing that problem! I promise I will donate if that plugin will work finally as I hope it can!

    Thanks in advance!!!

    http://wordpress.org/extend/plugins/subscribe2/

  2. mattyrob
    Member
    Plugin Contributor

    Posted 2 years ago #

    @Lutz.H,

    Try using the in-built Widget rather than another plugin. Enable it in Settings->Subscribe2 then place it in the usual way.

  3. Lutz.H
    Member
    Posted 2 years ago #

    Hi MattyRob,

    thanks for the quick response!

    I did so, but then I see in the webpage not the subscription form, but the hint "you can manage your subscription options from your profile". And before you ask: yes, I did fill out all the options in the settings (as far as I know), including the enabling ob that built-in widget.

    Why is that?

    Thanks again and kind regards,
    Lutz

  4. Lutz.H
    Member
    Posted 2 years ago #

    Sorry, MattyRob - my fault!

    I was logged in and in that case the widget shows that message as I checked out right now ;))

    Now I tried out the website being not logged in to WordPress and the form appears correctly. But the main problem stays the same: When I habe entered my mail adress and hit "subscribe" shows up the error message "Sorry, there seems to be an error on the server. Please try again later."

    What shall I do?

    Thanks again and kind regards,
    Lutz

  5. mattyrob
    Member
    Plugin Contributor

    Posted 2 years ago #

    @Lutz.H,

    Okay, you are seeing that message because the server is rejected the attempt to send the confirmation email.

    This is usually due to the selected sending address used by subscribe2 being 'off-domain' or not actually existing.

    So, you need to have an email address created that is on the same domain as your blog, so if your blog is http://www.example.com you need an email address like admin@example.com.

    Next you need to create a new user in WordPress using that email address and finally you need to go to Subscribe2->Settings and choose that user account as your email sender.

    If none of that helps you need to speak with your hosting provider about enabling email sending on your hosting plan or find way to obey any restrictions they have in place t combat spam.

  6. Lutz.H
    Member
    Posted 2 years ago #

    Hi MattyRob,

    thanks again!

    Got the point, but can't find a way to type in that "initially fist mail address". I already de-installed Subscribe2 and installed it again - but it kept it's settings so it doesn't ask for that "primary mail address" any more.

    Sorry for bothering you with details like that but I really checked all settings - I do not find it. And I can't erase this address from the mail list ...

    Kind regards,
    Lutz

  7. mattyrob
    Member
    Plugin Contributor

    Posted 2 years ago #

    @Lutz.H,

    You don't type the email address into Subscribe2. Add a user first at Users->Add New or edit an existing one at Users->All Users and then click edit under the user name you want to change. Update the email there under the Contact Info heading where is says E-mail.

    Now, take note of the user name and go to Subscribe2->Settings. Where it says Send Email From: under Notification Settings pick that user name from the drop down list.

  8. Lutz.H
    Member
    Posted 2 years ago #

    That's the Problem!
    Please see here: http://mobilwatch.net/wp-content/mediathek/screenshot.png
    When I click "edit" I can not edit the mail address, I'm only getting this window: http://mobilwatch.net/wp-content/mediathek/screenshot2.png
    I guess I'm totally wrong in that section "Subscribe2 - Subscribers", am I?

    Kind regards,
    Lutz

  9. Lutz.H
    Member
    Posted 2 years ago #

    Forget about it, found it! In WORDPRESS ... you wrote it, sorry!

  10. mattyrob
    Member
    Plugin Contributor

    Posted 2 years ago #

    @Lutz.H,

    You beat me there :) Wrong screen! I hope you're good now.

  11. Lutz.H
    Member
    Posted 2 years ago #

    Alright! Here we go: The problem was endeed that the mail address I used wasn't enabled to pull through scripts! Fixed that, works.

    BUT 1 more question and a bug report:

    First the bug: I have embadded some videos from YouTube into my website and these frames show up infront of the black confirmation layer you put over the site when showing the little confirmation window (which lays under the YouTube frames, too). So you can't read the signs clearly. Maybe you can fix that in future versions?

    Or is there a way I can disable that layer and the confirmation message? I don't need it because I route to a special page saying (in German) that a confirmation message is on its way.

    Second: Where/how can I change the English labels on the widget ("your mail", "enter email address...", "subscribe", "unsubscribe")?

    And at last (but that's a bonus, don't mind if this is not possible): Is there a way to change the layout of the widget on the website, let's say can I get a coloured background on that element?

    Thanks again and kind regards,
    Lutz

  12. mattyrob
    Member
    Plugin Contributor

    Posted 2 years ago #

    @Lutz.H,

    It seems you are using the AJAX form, unfortunately it seems that flash embedded YouTube videos demand the higher z-index unless set as transparent. You can disable the ajax form though in Subscribe2->Settings.

    If you just want to translate the plugin there are German translations here.

    You can style the background of the widget etc, using CSS and a DIV. In the Widget screen open up the Widget settings to enter the name of your DIV class.

  13. Lutz.H
    Member
    Posted 2 years ago #

    Thanks again!

    Without AJAX it works great!

    Languages: Alriht, found it. Where do I have to copy these files to? I tried a news subfolder "language" in the subscribe2 folder, but that didn't work ...

    Kind regards,
    Lutz

  14. mattyrob
    Member
    Plugin Contributor

    Posted 2 years ago #

    @Lutz.H,

    Just put the language files into the same folder, so wp-content/plugins/subscribe2/. Also make sure you have defined your language short code in the wp-config.php file.

  15. Lutz.H
    Member
    Posted 2 years ago #

    Just tried it right in that second by my own - thought, I cannot crash anything ;))
    Works! Wonderful!
    Thanks a lot!!!

    I still have to test some mailings, but the website integration works woderfully! Giving you feedback when I'm finished and this question i solved ;))

    Kind regards,
    Lutz

  16. Lutz.H
    Member
    Posted 2 years ago #

    Hi MattyRob,

    sorry for bothering you again. Searched the FAQ for a whole day, but couldn't find any hint. I need to embed the subscribe form ("enter mail", "subscribe", "unsubscribe") into a post, like a kind of picture (frame). Is that possible, too? Or is the only way to get access to the form via the widget?

    Thanks again in advance and kind regards,
    Lutz

  17. mattyrob
    Member
    Plugin Contributor

    Posted 2 years ago #

    @Lutz.H,

    Put the shortcode into the body of your post, it's [subscribe2]. The plugin will do the rest.

    Make sure you log out to see the form though.

  18. Lutz.H
    Member
    Posted 2 years ago #

    Sorry, I'm no pro at all: How do I have to insert thar code in a blog? I tried ist just like that <div subscribe2> but that didn't work. What's the HTML style I need to use?

  19. mattyrob
    Member
    Plugin Contributor

    Posted 2 years ago #

    @Lutz.H,

    You insert it exactly as I typed it! "[subscribe2]" without the quotation marks.

  20. Lutz.H
    Member
    Posted 2 years ago #

    Darn! Tried it that way, didn't work at the first time. Now it works, thanks again!!!

  21. Lutz.H
    Member
    Posted 2 years ago #

    Wonderful! Works! Thanks!
    But is this case I just need the "subscribe" button - is it possible to hide the "unsibscribe" button only in that imbedded fiel, not in the widget as well? Last question!!! ))

  22. mattyrob
    Member
    Plugin Contributor

    Posted 2 years ago #

    @Lutz.H,

    To hide the unsubscribe button use this:

    [subscribe2 hide="unsubscribe"]

    I'm looking forward to your donation now! :)

  23. Lutz.H
    Member
    Posted 2 years ago #

    Sure, thanks! PayPal ID #75U13842RH632230B

  24. Lutz.H
    Member
    Posted 2 years ago #

    By the way: 30 minutes ago passed the time for the first daily newsletter (yesterday I tested one-mail-per-post only) that should contain two posts from today, but nothing was sent out.
    Any idea what could go wrong here?

  25. mattyrob
    Member
    Plugin Contributor

    Posted 2 years ago #

    @Lutz.H,

    Thanks for the donation. :)

    What interval have you specified? It may take a while for the time to kind of catch up with your settings and for the emails to start sending. Go to Subscribe2->Settings and see of there is a Resend Digest button, if there is click it and it will probably tell you the email was empty.

  26. Lutz.H
    Member
    Posted 2 years ago #

    Hi!

    I set each day, 6pm. Even this morning no meassage has arrived, spam filters aren't active on that account.

    In "settings" I see a "send preview message" button only. Clicked it now, but no message is sent, too. Seems as if the system can't send automatic mails at all, just the ones from the subcription process ...

  27. Lutz.H
    Member
    Posted 2 years ago #

    And I just figured out another problem: I first viewed the site with Chrome and the IE Browser and here's the "enter mail" box too big, just about 10 or 15 pixels. Is there a way to shorten this box? I tried already by using a shorter text, but that didn't work out ...
    In Firebox the box fits great - I can't believe that the differences are so big!

  28. mattyrob
    Member
    Plugin Contributor

    Posted 2 years ago #

    @Lutz.H,

    The WordPress core has an known bug when sending emails with safe_mode switched on. http://core.trac.wordpress.org/ticket/20970

    Does that apply to you?

    You can change the width of the text entry box in the Widget settings in the admin area.

  29. Lutz.H
    Member
    Posted 2 years ago #

    Alright, I'll try to change the source code. Hope, that'll fix the problem. Or do you know any way to check if "safe_mode" is switched on - whatever that means?

  30. Lutz.H
    Member
    Posted 2 years ago #

    Oh, and I guess this one is a bug: When I click "send mail" - "send" I get a new, clean window saying only "Sure you want to do that?" - but not buttons or whatever to execute "yes" or "no" ...
    Tried it with IE, Chome and Firefox: always the same!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic